leap year issue

Advertisement

analog_boy
Joined:
Posts:
1
Location:
Minneapolis, MN

leap year issue

I think the date library winscp is using is broken... Any files/directories I've modified today have generated the error below:

Unexpected directory listing line '-rw-r--r-- 1 clfweb clfweb 276 Feb 29 00:40 .htaccess'.
Invalid argument to date encode

I've tested the theory and it's held true to any file I've modifed.

Thanks
Harlan Iverson

Reply with quote

Advertisement

Jim
Guest

Re: leap year issue

Same problem here. I upgraded to the latest (3.5.5beta) and still have the same problem -- any file with a date of Feb 29 chokes the directory scan.

analog_boy wrote:

I think the date library winscp is using is broken... Any files/directories I've modified today have generated the error below:

Unexpected directory listing line '-rw-r--r-- 1 clfweb clfweb 276 Feb 29 00:40 .htaccess'.
Invalid argument to date encode

Reply with quote

Aiea
Guest

Re: leap year issue

I have encounterd the same problem too. Looking for
a solution...or will everything "return to normal"
on 03/01/04??

Unexpected directory listing line 'drwxr-xr-x 2 bport bport 5120 Feb 29 00:52 area'.
Invalid argument to date encode


analog_boy wrote:

I think the date library winscp is using is broken... Any files/directories I've modified today have generated the error below:

Unexpected directory listing line '-rw-r--r-- 1 clfweb clfweb 276 Feb 29 00:40 .htaccess'.
Invalid argument to date encode

I've tested the theory and it's held true to any file I've modifed.

Thanks
Harlan Iverson

Reply with quote

Hitek
Joined:
Posts:
2

I'm seeing the same thing.

I have found a workaround:
in the advanced options, under environment/SCP, checking the "Alias LS to display group name" seems to fix the problem.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Re: leap year issue

Jim wrote:

Same problem here. I upgraded to the latest (3.5.5beta) and still have the same problem -- any file with a date of Feb 29 chokes the directory scan.
It works fine for me, both with SCP and SFTP. However I'm trying it now (1st March). Did the error disappear?
_________________
Martin Prikryl

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Hitek wrote:

I'm seeing the same thing.

I have found a workaround:
in the advanced options, under environment/SCP, checking the "Alias LS to display group name" seems to fix the problem.
It is completely different error. You probably did not have "group" name in the directory listing.
_________________
Martin Prikryl

Reply with quote

Hitek
Joined:
Posts:
2

martin wrote:

It is completely different error. You probably did not have "group" name in the directory listing.

Regardless of whether it is a completely different problem or not, it worked for me. At 10pm Feb28th my time (12am Feb29th server time) I started getting the set date error on both my servers. I changed the option in WinSCP, and the error went away, on both servers. That's why I called it a workaround and not a solution.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Solution

For list of reasons WinSCP cannot parse directory listing and possible resolutions, see documentation.
_________________
Martin Prikryl

Reply with quote

CalcMaster86
Joined:
Posts:
1

leap year again

I'm having the same problem--I've been connected to a remote server, working on it all day. When the server time flipped to February 29th, right at midnight, I was unable to list files in the directory properly. I get this error:

Unexpected directory listing line '-rw------- 1 wx22dt g01 17518 Feb 29 00:18 .sh_history'.
Invalid argument to date encode

My local time zone is 2 hours behind the server's. I tried another server as well in the same time zone, and I'm getting a similar error. I will post a follow up when we in the mountain time zone flip over also--I'll connect to a local server here.

Reply with quote

Advertisement

Guest

Looks like the problem wasn't a WinSCP bug but a linux bug itself--the support forum for the server announced a patch on the leap year issue.

Reply with quote

Advertisement

You can post new topics in this forum