Synchronize fails even though Ignore Permissions Error is On

Advertisement

foreerob
Joined:
Posts:
1

Synchronize fails even though Ignore Permissions Error is On

Synchronize fails even though Ignore Permission Errors is Set to On. This occurs for both the GUI and WINSCP.com. I was attempting to synchronize files to a remote server and was receiving the following error...

The server does not support the operation.
Error code: 8
Error message from server: SSHServerAPI.SFTP.fxp_attrs
Request code: 9


I am able to put the files using both the GUI and WinSCP.com with the -nopermissions and -nopreservetime parameters.

I am currently using WINSCP version 4.3.6. I have also set the Transfer Settings to the following...

Upload Options

* Set Permissions = Not checked
* Ignored Permission Errors = checked (but grayed out)
* Clear Archive attribute = unchecked



Common Options
* Preserve Timestamp = unchecked
* Calculate Total Size = unchecked


Filename Modification

File Name modifications = No change


The following is an excerpt from the WINSCP.com log. I noticed the PrTime: Yes is set. I inserted asterisks for security purposes...

. 2012-02-20 10:28:08.025 Copying 11 files/directories to remote directory "***"
. 2012-02-20 10:28:08.025 PrTime: Yes; PrRO: No; Rght: rw-r--r--; PrR: No (Yes); FnCs: N; RIC: 01; Resume: N (102400); CalcS: No; Mask: *.*
. 2012-02-20 10:28:08.025 TM: B; ClAr: No; CPS: 0; ExclM(No):
. 2012-02-20 10:28:08.025 AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
. 2012-02-20 10:28:08.025 File: "***"
< 2012-02-20 10:28:08.025 Script: Local '***' => Remote '***'
. 2012-02-20 10:28:08.025 Copying "***" to remote directory started.
. 2012-02-20 10:28:08.025 Binary transfer mode selected.
. 2012-02-20 10:28:08.025 Opening remote file.
> 2012-02-20 10:28:08.025 Type: SSH_FXP_OPEN, Size: 72, Number: 1283
< 2012-02-20 10:28:08.213 Type: SSH_FXP_STATUS, Size: 17, Number: 1028
. 2012-02-20 10:28:08.213 Discarding reserved response
< 2012-02-20 10:28:08.416 Type: SSH_FXP_HANDLE, Size: 12, Number: 1283
> 2012-02-20 10:28:08.416 Type: SSH_FXP_WRITE, Size: 1269, Number: 1798
> 2012-02-20 10:28:08.416 Type: SSH_FXP_CLOSE, Size: 12, Number: 2052
> 2012-02-20 10:28:08.416 Type: SSH_FXP_SETSTAT, Size: 76, Number: 1545
< 2012-02-20 10:28:08.635 Type: SSH_FXP_STATUS, Size: 17, Number: 1798
< 2012-02-20 10:28:09.010 Type: SSH_FXP_STATUS, Size: 17, Number: 2052
< 2012-02-20 10:28:09.010 Status code: 0
< 2012-02-20 10:28:09.010 Type: SSH_FXP_STATUS, Size: 44, Number: 1545
< 2012-02-20 10:28:09.010 Status code: 8, Message: 1545, Server: SSHServerAPI.SFTP.fxp_attrs, Language:
* 2012-02-20 10:28:09.010 (ETerminal) The server does not support the operation.
* 2012-02-20 10:28:09.010 Error code: 8
* 2012-02-20 10:28:09.010 Error message from server: SSHServerAPI.SFTP.fxp_attrs
* 2012-02-20 10:28:09.010 Request code: 9



Thanks for your help.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Synchronize fails even though Ignore Permissions Error is On

Well, if your server does not support setting timestamp of remote file, synchronization with WinSCP won't work. It does not make much sense to synchronize files, if you do not end up with the same timestamps on both sides.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum