Topic ""get -delete" and connection lost results in 0byte file"

Author Message
Guest




Hi

We use winscp.com for our FTP downloads. Recently we have experienced that connection issues in combination of deleting files which are already downloaded results in download of 0-byte files. The original files are not 0-byte files in the remote directory as you can see on the log example, but after a failed deletion it seems that the file is redownloaded after the connection is tried reestablished.

We use following for downloading files:
# Get all files, removing them once downloaded
get -delete *.* C:\EDI\Inboxes\XXX\

Please advice if we can make the winscp to rename the files with a timestamp or f.ex. ignoring 0-byte files ... any ideas are welcome.

log is attached
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24995
Location: Prague, Czechia
Thanks for your post.
I'll check the issue.
_________________
Martin Prikryl
majaht

Guest


Hi

Thanks! We are looking forward to hear about your findings.

Cheers,
Maja
Guest




It happened once more -the new log file is attached as well
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License