password with @

Advertisement

rpolichetti
Joined:
Posts:
1
Location:
CA

password with @

While using this template:
sftp://martin:mypassword@example.com

the password I'm trying to use has the @ symbol which is confusing the parser.
Can the password be quoted or the @ in the password be escaped or something else?
Richard

Reply with quote

Advertisement

Alexyau
Guest

I read the link and understood that special character needed to be replaced by %XX where XX is hexadecimal ASCII code.

I tried to connect to the FTP server(Windows 2008) and the user name is abc-dms\ABCDE. I have tried abc%2Ddms%5CABCDE and abc-dms%5CABCDE but both didn't work.

Any other suggestion?

Alex

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Actually there's no need to encode nether \ nor -.
So the problem has to be elsewhere.
Please post a full log file showing the problem.
_________________
Martin Prikryl

Reply with quote

Alexyau
Guest

First, I am running the script in command-line.

For example, running test.bat to run test.txt.

test.bat: winscp /console /script=c:\test.txt

test.txt:

option batch abort
option confirm off
open pcn-dms\DCN020A004:12345@site
cd /test_transfer_log
lcd C:\New_DMSInterface_Test\LOG
get -delete *.*
cd /test_transfer
lcd C:\New_DMSInterface_Test\PROCESSED
get -delete *.*
close
exit

BTW, how I can get the full log file if I run the script in command-line mode.

Alex

Reply with quote

Alexyau
Guest

Resolved:

As suggested, I found the /log option, added to the command line and reviewed the log.

The problem was the default protocol was using SFTP while my remote server was using FTP. So I have added "ftp://" in the open command and it worked.

Thanks very much for your assistance and WinSCP is indeed a great product.

Alex

Reply with quote

Advertisement

You can post new topics in this forum