WinSCP not prompting for new Password

Advertisement

christian.sandrini@...
Guest

WinSCP not prompting for new Password

Hi

As per this website (https://winscp.net/eng/docs/ui_authenticate#password_change) it says that it should prompt for a new password when the account has been disabled. Somehow it does not work on my system:

I have disabled an account on the sftp server

When trying to login via SSH it prompts for a new password

WARNING: Your password has expired.
You must change your password now and login again!
Changing password for user ex2m3.
Changing password for ex2m3.
(current) UNIX password:

But in WinSCP i just get the error
Cannot initialize SFTP protocol. Is the host running a SFTP server?

Any ideas how I can fix that?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: WinSCP not prompting for new Password

christian.sandrini@me.com wrote:

As per this website (https://winscp.net/eng/docs/ui_authenticate#password_change) it says that it should prompt for a new password when the account has been disabled. Somehow it does not work on my system:
No, it says that WinSCP supports password change request initiated by the server. So your server probably does not support this.
_________________
Martin Prikryl

Reply with quote

christiansandrini
Guest

christian.sandrini@me.com wrote:

How can I configure the server to support it then? I use openssl-1.0.0-20

To add on this. The server is requesting for a new password. See first post. But it only works using SSH. Not over WinSCP

Reply with quote

chrissandrini
Guest

christiansandrini wrote:

christian.sandrini@me.com wrote:

How can I configure the server to support it then? I use openssl-1.0.0-20

To add on this. The server is requesting for a new password. See first post. But it only works using SSH. Not over WinSCP

I meant openssh (openssh-5.3)

Reply with quote

chrisSandrini
Guest

Nevermind. I found the solution. Maybe you can add it to your Documentation

I use openssh 5.3

change the following in sshd_config

UsePAM yes
ChallengeResponseAuthentication yes
PasswordAuthentication no


This will work

Reply with quote

Advertisement

You can post new topics in this forum