Topic "scp/sftp-url-bugs"

Author Message
Zoyo

Guest


Hi.

I've got some problems with this new URLs.
1. If the URL contains a whitespace then winscp can't open the directory. It breakes the pathname at this whitespace.

2. It seems that I can't use URLs pointing to files. winscp tries to do a cd to that URL. This gives an error like: "-bash: cs /home/foo/bla.pdf: Not a directory." with the URL scp://server/home/foo/bla.pdf
I think that the application linked to the filetype should start like it does when klicking on a file manually.

regards,
Zoyo
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
I can confirm the both problems. I'll try to do something with it.
_________________
Martin Prikryl
nils

Guest


prikryl wrote:
I can confirm the both problems. I'll try to do something with it.


Hi,
these problems still exists in 3.7.0 Build 254.
Any hints?

Thanks,
Nils
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
nils wrote:
Hi,
these problems still exists in 3.7.0 Build 254.
Any hints?

The second problem is AFAIK resolved. If you use URL http://server/path/file the file will be downloaded. but now I have maybe noticed small problem. The path cannot be relative to home directory, it must be full path.

The first problem maybe still exists, but I'm not able to reproduce it. Can you tell me what exactly are you doing and on what version of Windows, with what browser?
_________________
Martin Prikryl
Guest




Quote:

The second problem is AFAIK resolved. If you use URL http://server/path/file the file will be downloaded. but now I have maybe noticed small problem. The path cannot be relative to home directory, it must be full path.

The first problem maybe still exists, but I'm not able to reproduce it. Can you tell me what exactly are you doing and on what version of Windows, with what browser?


Hi,

Windows XP professional + IE 6 SP2 fully patched + Mozilla 1.7.3

ok second problem is solved, but only if there is no whitespace. I tried to replace whitespaces in the url with %20 or '+' (sftp://foo.bar.com/file%20blubb.txt). It gives me a "Invalid access to memory" error.
I can't confirm the relativ path issue!

Now to the first problem:
i.e. url: "sftp://foo.bar.com/dir with whitepace" error msg : File or folder 'dir' does not exists.... as expected.
i.e. url: "sftp://foo.bar.com/dir%20with%20whitepace" error msg : invalid access to memory

thanks,
Nils
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Change SFTP/SCP handler as follows (in windows registry)

Code:
REGEDIT4

[HKEY_CLASSES_ROOT\SFTP\shell\open\command]
@="\"path_to_install_dir\\WinSCP3.exe\" \"%1\""


Code:
REGEDIT4

[HKEY_CLASSES_ROOT\SCP\shell\open\command]
@="\"path_to_install_dir\\WinSCP3.exe\" \"%1\""


Note the added quotes around %1.

This way it works with IE the both ways (with space and with %20). IE replaces user-entered space for %20 automatically. But before it passes the URL to WinSCP it replaces %20 with space back.

Mozilla does not perform the replacement in either way. So with it the syntax with %20 will not work.

I'll add support for %XX to next version.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License