Could not retrieve directory listing

Advertisement

pgfiore
Guest

Could not retrieve directory listing

5.0.7 beta (using ACCT)
during intial handshake WinSCP fires:
Error listing directory ':F:$ISP815'
Could not retrieve directory listing. Not changed, Posix cannot be accessed.

Then, pressing OK, the tree (left side) seems correct, but there are no files (right side)

The host is a Fujitzu BS 2000 server which uses EBCIDC coding; i'm quite sure it could be the reason of the error.

(btw Windows ftp lists files correctly)

Thanks for any hints.
Ciao
pf

Reply with quote

Advertisement

pgfiore
Guest

Is it a big issue? Or could it be easely fixed?
Seems just? a problem in the initial exchange; the server can use ascii then and even Windows ftp.exe works...
Thank in advance for the support
ciao

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

It's about path format. Command line FTP clients do not care, because the end-user takes care of understanding path format. But GUI client has to understand it.
_________________
Martin Prikryl

Reply with quote

pgfiore
Guest

To avoid the ABCDIC issue listed here I'm trying to use directly the command line.
I hoped the -transfer on the GET command could make the trick, but with no success.

I'm sure the file exist in the default folder because I used copy/paste from the working Microsoft ftp script (i.e. type A get sx-liquidati-au)

C:\WinSCP>winscp /command "open ftp://isp:@128.1.1.19 -rawsettings ftpAccount=815" "get -transfer=ascii sx-pagati-au" "exit"
Connecting to 128.1.1.19 ...
Connected with 128.1.1.19. Waiting for welcome message...
Password: [I just pressed enter here]
Connected
Starting the session...
Reading remote directory...
Session started.
Active session: [1] isp@128.1.1.19
Can't get attributes of file 'sx-pagati-au'.
File or folder 'sx-pagati-au' does not exist.

Reply with quote

Advertisement

You can post new topics in this forum