Just upgraded to the beta client lost all my sessions!

Advertisement

Syvil
Guest

Just upgraded to the beta client lost all my sessions!

Hi,

I just upgraded to beta 5.0.7 and I lost all my saved sessions besides what was stored in the registry before. I have never had this issue before someone please help me! :evil:

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,123
Location:
Prague, Czechia

Re: Just upgraded to the beta client lost all my sessions!

What version were you using before? Were you using registry or INI file to store the configuration?
_________________
Martin Prikryl

Reply with quote

Guest

Hi,

I was able to fix this by downgrading back to 4.3.7 (Build 1679)

I'm using INI storage the entries I saw after the upgrade appeared to be in the registry.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,123
Location:
Prague, Czechia

Where do you have you INI file stored?
_________________
Martin Prikryl

Reply with quote

syvil
Guest

Hi,

Under Preferences -> Storage -> Configure storage -> INI file (WinSCP.ini) is checked.

Should I export WinSCP.ini and Import into the beta?

I want to test the beta since I often have several connections open and if one times out or disconnects WinSCP will crash at times.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,123
Location:
Prague, Czechia

On Windows Vista and newer, when WinSCP 4.x tries to store INI file into Program Files folder, it gets redirected into Virtual folder. WinSCP 5.x is not, so it won't find the INI file created by 4.x.
_________________
Martin Prikryl

Reply with quote

skullmonkey
Guest

I'm on 5.9.4 and I lost all my sites this morning. I wasn't even updating. They were locally stored in .ini file. Any chance on recovery?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,123
Location:
Prague, Czechia

skullmonkey wrote:

I'm on 5.9.4 and I lost all my sites this morning. I wasn't even updating. They were locally stored in .ini file. Any chance on recovery?
Sorry, this is too broad. We need to know more.

Is the configuration still pointing to the same INI file?
Does the INI file contain the sessions, if you open it in text editor?

Reply with quote

Advertisement

skullmonkey
Guest

Yes. The path is the same but I cannot see the sites at the end of the file.
The path to Putty is correct thou.
txs

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,123
Location:
Prague, Czechia

skullmonkey wrote:

Yes. The path is the same but I cannot see the sites at the end of the file.
The path to Putty is correct thou.
txs
I'm not sure we can help you. I cannot imagine how it happened. But the sites were somehow removed from the INI file, there's hardly a way to recover them.

Reply with quote

Advertisement

You can post new topics in this forum