Error while uploading files using batch script

Advertisement

guptamrishabh
Joined:
Posts:
2
Location:
India

Error while uploading files using batch script

Hi All,
I am new to WinSCP scripting. I have wrtten a script which is uploading the files using a temp scipt file with the following syntax:

put -delete *.txt

But during execution of the script always last file fails to transport to the remote SFTP server. The error logs are attached.

Please help me in avoiding such errors.

Thanks in advance.
---Rishabh
Description: This is actually an xml log file being created by WinSCP itself.

Reply with quote

Advertisement

guptamrishabh
Joined:
Posts:
2
Location:
India

Re: Error while uploading files using batch script

martin wrote:



Thanks Martin,
I have tried again with the suggestion u have made in the first link and got success in the same.

But my query then would be that if this be the problem it should be for all the files. whereas some of my files got successfully transferred as evident in the logs.

Could you please elaborate on that..

Thnaks
--Rishabh

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,659
Location:
Prague, Czechia

Re: Error while uploading files using batch script

guptamrishabh wrote:

But my query then would be that if this be the problem it should be for all the files. whereas some of my files got successfully transferred as evident in the logs.
The Transfer Resume/Transfer to Temporary Filename is by default enabled only for files over 100 KiB:
https://winscp.net/eng/docs/ui_pref_resume
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum