Crash winscp 5.0.7 (build 2268)


Vincent Diepeveen

Crash winscp 5.0.7 (build 2268)


First time i tried setup secure ftp myself at linux box.
To connect to it i also installed winscp. Winscp crashes,
it's not deterministically crashing though and each new attempt i get
different errors IF it crashes.

Tried install winscp 5.0.7 buil 2268 at windows vista ultimate
which runs at 2 socket Xeon L5420 machine with supermicro motherboards.

the machine is NOT on the internet. It's internal connected to a
linux box with a crossover cable. I turned off firewall of that linux box
just to experiment getting the ftp server and client setup correctly.

regrettably winscp crashes or doesn't get in.

The linux box is setup to support SSL1,2,3 and TLS. Encryption forced.
RSA key at linux server box 2048 bits.
ftp server is vsftp at debian squeeze.
hostname port 21

In winscp settings:

It crashes everywhere directly after certificate acception.
When i retry with SSL explicit encryption, it also crashes and reports
that it tried to do something in windows vista that isn't allowed somehow.

file protocol : ftp
encryption: ssl explicit encryption
logging : enable session logging on level "normal"
log to file : c:\install\winscp.log
i didn't mark the 'show log window' as that feature is total buggy,
the window you see but it doesn't scroll down and when it's not connecting,
the window disappears already so you never can scroll in that window.

i didn't change environment.

connection: passive
internet protocol version : ipv4 is what i selected

let me report exactly this crash:

windows reports: "abnormal program termination"
In the logfile from vsftp where i turned all sorts of debugging on i could find, i see lots ofl ines, but not sure that's this session or what the server offers to the client.

the interesting line:

"ssl version: TLSv1/SSLv3, SSL cipher: DES-CBC3-SHA, reused, no cert"

Does the client need a certificate????
If so how do i generate one for it?

The vsftp does have a certificate i selfsigned of course with 2048 bits RSA.
Default examples i seeo nline is just 1024 bits - i find that too little.

Note DES and CBC not my favourite.

Now i select in client TLS explicit encryption, i cannot select which encryption to select, maybe vsftp server is doing that?

Now the so manieth time i try it doesn't crash yet i see big error in the debug of vsftp that winSCP ships:

DEBUG: Client (that's the winscp client box), "SSL ret : 4294967295, SSL error: error:00000000:lib(0):func(0):reason(0), errno: 0"

That seems like some overflow of a 32 bits int or something?

Is this connection using any encryption at all??

Thanks for any tips and advices
as i'm not registered here drop me a line at <removed by admin> thanks,
Vincent Diepeveen

Reply with quote


Site Admin
martin avatar
Prague, Czechia

Re: Crash winscp 5.0.7 (build 2268)

Thanks for your report.
I have sent you an email.
Martin Prikryl

Reply with quote


You can post new topics in this forum