Topic "Bug with transferring files with certain characters"

Author Message
travla

Guest


Hi there,
It is my first go at reporting a bug for WinSCP, so hopefully I have followed the instructions properly.

1. I am using WinSCP 4.3.7 (Build 1679)
2. I have always had this problem (i.e. not associated with a particular upgrade)
3. I am using the SFTP-3 transfer protocol
4. I am using the GUI with the Commander Interface
5. I am using Windows Vista SP2 (32-bit)

The problem I am having is transferring files with certain characters from my local drive to my remote drive. The characters which seem to give trouble are for example Ş or ı (if they don't appear to look wrong, I pasted an S with a line under it and an i without a dot). When files with those sorts of characters are attempted to be transferred, WinSCP reports the following error:

System Error. Code: 2.
The system cannot find the file specified.

What is also interesting is that the GUI does not show these files in the remote drive with the correct characters. For example, it displays the Ş as a regular S and the ı as a regular i. However, in windows explorer, these characters are displayed correctly. Another intersting symptom ofthis bug is that when you right mouse click on files with these characters in the WinSCP GUI, the file disappears under your mouse, and brings the file below it under the context menu. If it helps, it does not affect all foreign/non-english characters. The following couple seem to work fine, and there may be others:

Hopefully I have provided sufficient detail to replicate this bug, please let me know if I need to provide further details.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
Can you please first try using 5.0.x beta? It has better support for Unicode.
_________________
Martin Prikryl
travla

Guest


prikryl wrote:
Can you please first try using 5.0.x beta? It has better support for Unicode.


I am hesitant to install beta software, can you give your best estimate as to how much longer 5.0.x will be in beta? The problem is isolated to a handful of my files, and I can wait if the beta is close to release.

On a separate note, were you able to reproduce what I reported as a bug?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
In couple of weeks/few months.
_________________
Martin Prikryl
Guest




Thank you for the response, it is much appreciated.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License