Server unexpectedly closed network connection

Advertisement

Zeroes
Joined:
Posts:
7

Server unexpectedly closed network connection

Hi!

I check winscp439 and winscp508 RC, under Win7 x86 sp1. Server - SPLAT system (based on Red Hat Linux) with Check Point NG v70.50

problem: i get error "Server unexpectedly closed network connection" when i try
transfer file from server (SCP connect) with size 102,400,000 bytes. Destination
file on disk after close connection ~ 0.5-1.5 Mb. %temp% and destination path
have some Gb free space.

Small files I transfer without any problem (test less 2Mb file)

I test under SecureFX7.0 build 326 - this program successful transfer my file under SCP.
Description: log under debug2

Reply with quote E-mail

Advertisement

Zeroes
Joined:
Posts:
7

Re: Server unexpectedly closed network connection

I test again

trouble 100% begin when I download from server to client more when 10mb file, upload do it without troubles (check up to 200 mb ok). in log file \var\log\secure I found:
Aug 7 17:30:54 cpgw sshd[6286]: fatal: buffer_append_space: alloc 10498048 not supported

SecureFX again work without troubles.
......
Ok, i search on google about 'buffer_append_space' and found answer what this bug OpenSSH, but client may workaround this trouble and winscp419 work fine.


Dear Mr. Martin Prikryl how time need to relize this:
Currently the "Optimize connection buffer size" has to be explicitly set to "off" when connecting to buggy version of OpenSSH.

? :)

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Server unexpectedly closed network connection

Thanks for your investigation. Can you please try to reproduce this also using SFTP protocol?

Reply with quote

Zeroes
Joined:
Posts:
7

Re: Server unexpectedly closed network connection

martin wrote:

Thanks for your investigation. Can you please try to reproduce this also using SFTP protocol?

when i try connect i get:
Cannot initialize SFTP protocol. Is the host running a SFTP server?


I open issue about my trouble and Check Point do it for our company private hotfix (I try accept this tomorrow), But anyway i wish what winscp may use workaround (automatic or manually) for this problem.

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Server unexpectedly closed network connection

Zeroes wrote:

But anyway i wish what winscp may use workaround (automatic or manually) for this problem.
Well, there's manual workaround, as you have found out yourself.
_________________
Martin Prikryl

Reply with quote

Zeroes
Joined:
Posts:
7

Re: Server unexpectedly closed network connection

martin wrote:

Zeroes wrote:

But anyway i wish what winscp may use workaround (automatic or manually) for this problem.
Well, there's manual workaround, as you have found out yourself.

use SecureFX or old version WinSCP? I think user want use one latest version WinSCP :)

PS. hotfix for Check Point system resolve my problem.

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Server unexpectedly closed network connection

I mean this:
Currently the "Optimize connection buffer size" has to be explicitly set to "off" when connecting to buggy version of OpenSSH.

_________________
Martin Prikryl

Reply with quote

Zeroes
Joined:
Posts:
7

Re: Server unexpectedly closed network connection

martin wrote:

I mean this:
Currently the "Optimize connection buffer size" has to be explicitly set to "off" when connecting to buggy version of OpenSSH.

Thank you for information...., now I know who this options exist already, i don't know about this earlier....
i check already work fine with buggy SSHd... I report wishes to author plugin for FAR - Netbox about possible use this options.

Last edited by Zeroes on 2012-08-22 08:23; edited 1 time in total

Reply with quote E-mail

Zeroes
Joined:
Posts:
7

Re: Server unexpectedly closed network connection

martin wrote:

I mean this:
Currently the "Optimize connection buffer size" has to be explicitly set to "off" when connecting to buggy version of OpenSSH.

Anyway i suggestion wishes: add baloon notification with text "has to be explicitly set to "off" when connecting to buggy version of OpenSSH" when mouse around gui options "Optimize connection buffer size".

Reply with quote E-mail

Advertisement

You can post new topics in this forum