Topic "Problem with return from passworded 3D screensaver"

Author Message
SenorPlankton

Guest


After a windows 3d screensaver (3d pipes, flowerbox etc) has been dismissed and the password entered, WinSCP throws an error trying to connect to a disconnected drive and no drives in the drive dropdown can be accessed.

This only appears to happen if WinSCP is set to 'Commander' interface - with the 'Explorer' interface, no error is thrown, but the remote directory listing disappears.

- Set Windows screensaver to 3d pipes and 'password protected'
- With WinSCP open and connected to a session with C: drive active in the left pane, wait for the Windows screensaver to start.
- Dismiss the screensaver, and enter password - WinSCP throws an error trying to connect to a disconnected drive: "Drive D: is not ready" in my case. The displayed local path is still C:..., but nothing is shown in either pane.
- Attempting to select drives (connected or not) from the local dropdown navigates to random folders on the C: drive, and occasionally throws an 'invalid access to memory' error. WinSCP fails to function correctly until restarted.

HP Dx2400 2.8GHz Intel Core 2 Duo
Windows XP Pro SP3
WinSCP v5.0.8 (Build 2438)
winscp-sc-pw-error.PNG (65.93 KB) [Download]

Description: screen shot of drive error

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
I hope this is related to:
https://winscp.net/tracker/show_bug.cgi?id=899

Can you send me an email, so I can send you back a dev version of WinSCP for testing? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
SenorPlankton
[View user's profile]

Joined: 2012-08-23
Posts: 2
Email sent.

Further info -

I also found today that the same error occurs when you unlock a machine that has been locked because it's being accessed by RDP (remote desktop).

Basically -
- On 'work' machine start up WinSCP and connect to a host
- Leave machine logged in and go home
- On 'home' machine connect via RDP to 'work' desktop
- Close remote desktop without logging off and go to work
- Unlock work machine with ctl-alt-del, when unlocked WinSCP immediately throws the same error
SenorPlankton
[View user's profile]

Joined: 2012-08-23
Posts: 2
Looks like bug 899 fixes both of these issues!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License