SFTPv4 Not Supported Error

Advertisement

iceparrot
Joined:
Posts:
3

SFTPv4 Not Supported Error

Using WinSCP 3.56
Server is VShell 2.02

When I connect to my SSH server, I get a exit 0 error.

Upon looking at the server logs:

16:21:16,conn,00022: Session channel open request accepted.
16:21:16,sftp,00022: Unsupported SFTP protocol version 4
16:21:16,conn,00022: Session channel has been closed (pid: none).
16:21:16,sftp,00022: Sftp subsystem terminated.
16:21:16,conn,00022: Connection closed.

My understanding from reading the forum posts is that WinSCP should run version 3 if the server will not support version 4. Is there a way to force WinSCP to run a certain version?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,469
Location:
Prague, Czechia

Re: SFTPv4 Not Supported Error

I'm using VShell (the latest version) and I have no problem. The version I use supports SFTP4.

Anyway, it is the server who decides what version of SFTP is going to be used. The client only sends the highest supported SFTP version and the server chooses the either it (if it supports it) or any lower. So I do not understand at all what does the error means.

Try to upgrade to the latest VShell.
You may also try WinSCP 3.1, which supports only SFTP3.
_________________
Martin Prikryl

Reply with quote

iceparrot
Joined:
Posts:
3

Re: SFTPv4 Not Supported Error

martin wrote:


Try to upgrade to the latest VShell.
You may also try WinSCP 3.1, which supports only SFTP3.

The newest VShell (2.2.5) works fine with WinSCP. Thanks for the advice.

I did try another SFTP program before I switched to the newer Vshell, and VShell sent it the right version of SFTP and it connected fine, thus I'm not sure if it was a small bug in Vshell or WinSCP

Reply with quote

Advertisement

You can post new topics in this forum