Cannot connect when remote folder was deleted

Advertisement

JQu
Joined:
Posts:
2

Cannot connect when remote folder was deleted

WinSCP v.5.1.1

WinSCP remembers path on remote machine and when connects again, remote path is the same as was last time.
Problem occurs when the remote folder was deleted - winscp cannot connect until I create deleted folder or
delete remembered path from system registry.

Sorry for my terrible English.

regards,
JQu

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Cannot connect when remote folder was deleted

Can you please attach few screenshots showing that? And a session log file. Thanks.
_________________
Martin Prikryl

Reply with quote

JQu
Joined:
Posts:
2

Re: Cannot connect when remote folder was deleted

I think I know what the problem is. There is QNX4 operating system on the remote machine, which generates problem.
When WinSCP try to set current directory, during connection establish, executes command:

cd "/AAAA" ; echo "WinSCP: this is end-of-file:$?"

on Linux machine the response is:

-bash: cd: /AAAA: No such file or directory
WinSCP: this is end-of-file:1

but on QNX4 machine the response is:

/AAAA: bad directory

there is no "WinSCP: this is end-of-file" in reponse.
WinSCP timeouts when waiting on it.
It seems that QNX4 shell breaks executing commands on cd command error.

Look at the attached log.

regards

Reply with quote

Advertisement

You can post new topics in this forum