Topic "Sync syncing unchanged files"

Author Message


I've got a very simple script to sync with remote. Right now there are only 5 files in the folder i'm syncing and none of them have changed in a day or so. The first time I sync, it synced all 5 files. However, now it seems to sync two of the five files even though they haven't changed. If I run sync through the GUI it seems to work correctly, confirming that "no differences have been found". The command i'm using is:

synchronize remote K:\redikerbackups /private/adminplus

I also tried synchronize -criteria=time remote K:\redikerbackups /private/adminplus
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
Please read FAQ:

If that does not help, come back.


Even stranger... if I double click and run normally it syncs fine. If I run as admin, I now get nothing to synchronize.


The time on the server seems to be in sync with mine. Do i need to set the preserve timestamp option? I didn't see a command to do this, only a checkbox.

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License