Trying to save file on wrong session

Advertisement

ThaKladd
Joined:
Posts:
1
Location:
Oslo, Norway

Trying to save file on wrong session

Opened two sessions. One with ftp conection to my web server, other one to a sftp server. This worked totally fine, until while saving the files editing directly on the web server stopped working and I got a error message (what it said I do not remeber - something about no access to save file). I restarted WinSCP and it worked alright. Did not think this was any kind of serious problem then.

A week later I emailed with the company of the sftp server, and they showed me their log - and it seemed that I was trying to save the files located on my web server on to the sftp server (failing of course). Somewhere there had to be a mixup with the two sessions - that is all I can tell. Maybe after session timout/connection lost - I had been connected for a while to both and experienced at least one reconnect.

It may help to mention that I was trying to connect to the sftp server from the web server at the time in PHP(using different methods - ), possibly leaving a connection open, but I dont get why editing a file on the web server would try to save it on the sftp server when in WinSCP.

I did not manage to replicate it. Still, it was serious enough to mention here, as I did not see it mentioned in the bugfix list.

I use WinSCP 5.1 // Commander // Win7 // Didn't have logging enabled.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Trying to save file on wrong session

Thanks for your report.
Please, let us know if it ever happens again.

Reply with quote

Advertisement

You can post new topics in this forum