Change Storage Error

Advertisement

tbharp
Joined:
Posts:
2

Change Storage Error

An administrator installed WinSCP.
They copied my WinSCP.ini file from another machine to the program folder.
My stored stored sessions and preferences all show up in WinSCP on the new machine.
But, now I can't change my preferences....
I go to change the editor path (since the path is from the old machine), and it works until I quit and restart. It reverts back to the old path every time I restart WinSCP.
I tried changing the preferences storage to "Windows Registry" from "INI file", but after I click "OK" on the Preferences it gives an error:

(X) 151
System Error. Code: 5.
Access is denied

I'm not an administrator for this machine. What do I need to do to change my preferences and have them save normally?

Thanks.

Reply with quote

Advertisement

tbharp
Joined:
Posts:
2

I also can't change my stored passwords.

It says:

(X) Can't create file 'C:\Program Files\WinScp\WinSCP.ini'

System Error. Code : 5.
Access is denied

Reply with quote

TMMC
Guest

Re: Change Storage Error

tbharp wrote:


System Error. Code: 5.
Access is denied

I'm not running Administrator account neither, but to be specific I use account with administrative privileges (on nice but sometimes strange OS - Windows 8.1 Pro). I've got the same problem if I run WinSCP 'normally' - ie. double click. If I run it from right click and choose 'run as administrator' it lets me write/edit session preferences within INI file. Maybe it will work for you if you are in Administrators group.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,809
Location:
Prague, Czechia

Re: Change Storage Error

TMMC wrote:

I'm not running Administrator account neither, but to be specific I use account with administrative privileges (on nice but sometimes strange OS - Windows 8.1 Pro). I've got the same problem if I run WinSCP 'normally' - ie. double click. If I run it from right click and choose 'run as administrator' it lets me write/edit session preferences within INI file. Maybe it will work for you if you are in Administrators group.
Again, you should not store an INI file to location that requires admin privileges to write to. Move your INI file to writable location, see:
https://winscp.net/eng/docs/config#ini
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum