Ignore permission errors

Advertisement

ndberesford
Joined:
Posts:
3

Ignore permission errors

Hiya

I'm sure I'm missing this somewhere obvious but I'm getting errors on a transfer and it's telling me to use the "Ignore permission errors" option, but I can't see where to set that in code. I'd assumed in TransferOptions but there's nothing obvious in there. Am I being that clueless?

Thanks!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,271
Location:
Prague, Czechia

Re: Ignore permission errors

You cannot set that in .NET assembly. Though there will likely be a better solution. But I need to see completed error message.
_________________
Martin Prikryl

Reply with quote

ndberesford
Joined:
Posts:
3

Hi Martin

That's a bit of a shame. The error message is:

Upload of file 'EDIMessage4423-9491.edi' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.

I assume it's the permissions on the server I'm uploading to, but that's out of my control so I can't make changes there.

Basically it's an automated file upload that uses TransferOperationResult.IsSuccess to flag a file as uploaded in a DB. The code was working fine until there was a change in the server I was uploading to and now I get that message. The file is being uploaded as I can manually login and see it, it's just the IsSuccess flag is staying false. I'm leaving the TransferOptions.FilePermissions set to the default so perhaps the timestamp?

Thanks

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,271
Location:
Prague, Czechia

TransferOptions.PreserveTimestamp = false;
TransferOptions.FilePermissions = null; // that's default
_________________
Martin Prikryl

Reply with quote

ndberesford
Joined:
Posts:
3

Hi Martin

Thanks very much for that. Classic case of not being able to see the wood for the trees. I was so hungup looking to disable errors that I didn't think about addressing them. That's sorted that issue out.

Thank you

Reply with quote

Advertisement

You can post new topics in this forum