WINSCP .EXE V5.1.4.0 Does not Match Assembly V5.2.0.0

Advertisement

Bill123
Joined:
Posts:
1

WINSCP .EXE V5.1.4.0 Does not Match Assembly V5.2.0.0

Hi folks,
Just downloaded the latest WINSCP and .NET Assembly Automation versions. Seems there is an incompatibility
issue (Exception calling "Open" with "1" argument(s): "The version of c:\program files\winscp\winscp.exe (5.1.4.0) does not match version of this assembly c:\program files\winscp\WinSCP.dll (5.2.0.0). You can
disable this check using Session.DisableVersionCheck (no recommended).").

Just used the standard Powershell script provided.

Regards,
Bill

Reply with quote

Advertisement

ucg
Joined:
Posts:
1

Yes looks like <invalid hyperlink removed by admin> file contains the dll that uses WinSCP 5.2 which has not been released yet.

Can we get the zip updated with the correct version of the dll please?

thx

Reply with quote

dwe
Joined:
Posts:
1

WINSCP .EXE V5.1.4.0 Does not Match Assembly V5.2.0.0

I have the same problem.
Setting "session.DisableVersionCheck = True" leads to the following error:
"Incompatible protocol version 6 of extern console"

Reply with quote

Michal
Joined:
Posts:
1
Location:
Poland

winscp.exe (5.1.4.0) WinSCP.dll (5.2.0.0)

Hi,
I stucked with my scripts because of this problem ..Do You know when it could be resolved ?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: WINSCP .EXE V5.1.4.0 Does not Match Assembly V5.2.0.0

I have released development version of the .NET assembly with 5.1.4 by mistake. Will fix it shortly. Meanwhile you can use 5.1.3.

Reply with quote

Advertisement

You can post new topics in this forum