Automation using Bat/Script via Window server 2012 Scheduler

Advertisement

cunning
Joined:
Posts:
3

Automation using Bat/Script via Window server 2012 Scheduler

I have used INI method in WINSCP..
When i try to manually run the batch file where Pageant is on system tray. Connection is fine. it does not ask me any password or phrase.
But when i try to run it via Task Scheduler it does not check pageant and ask me for password. DO you have any idea about it please let me know!

Reply with quote

Advertisement

cunning
Joined:
Posts:
3

Re: Automation using Bat/Script via Window server 2012 Scheduler

I don't think it solves the issue. My question is why it does authenticate with Pageant when i run Batch file manually but not from windows Scheduler??
Have anybody tried it?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: Automation using Bat/Script via Window server 2012 Scheduler

cunning wrote:

I don't think it solves the issue. My question is why it does authenticate with Pageant when i run Batch file manually but not from windows Scheduler??
Have anybody tried it?
Because the pageant needs to run in the same Windows session as WinSCP. Pageant is really not intended for automation.
_________________
Martin Prikryl

Reply with quote

cunning
Joined:
Posts:
3

Re: Automation using Bat/Script via Window server 2012 Scheduler

Actually it was Pass Phrase issue on Privatekey. Is is possible to pass through phrase in script file?
I have to remove Pass phrase to resolve the issue!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: Automation using Bat/Script via Window server 2012 Scheduler

cunning wrote:

Actually it was Pass Phrase issue on Privatekey. Is is possible to pass through phrase in script file?
I have to remove Pass phrase to resolve the issue!
This request is being tracked already:
https://winscp.net/tracker/show_bug.cgi?id=816
_________________
Martin Prikryl

Reply with quote

miro_ilias
Guest

Re: Automation using Bat/Script via Window server 2012 Scheduler

cunning wrote:

I don't think it solves the issue. My question is why it does authenticate with Pageant when i run Batch file manually but not from windows Scheduler??
Have anybody tried it?

I have the same problem - Windows 7 scheduler can not authenticate with Pageant, only from batch file manually.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: Same Issue...

jdantzler wrote:

I am having the same issue. It would be great if we can come up with a solution to this problem.
Solution is in my very first response above.
_________________
Martin Prikryl

Reply with quote

jwd41190
Guest

Re: Same Issue...

martin wrote:

jdantzler wrote:

I am having the same issue. It would be great if we can come up with a solution to this problem.
Solution is in my very first response above.

Still does not work even without a passphrase...Thanks

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: Same Issue...

jwd41190 wrote:

Still does not work even without a passphrase...Thanks
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum