'STAT' command in winscp.com prepends '/'

Advertisement

cordata
Joined:
Posts:
1
Location:
USA

'STAT' command in winscp.com prepends '/'

Hello and thanks for the great software!

A relatively small problem but if you don't know can cause a few problems.

I'm doing some scripting with winscp.com and want to look at a file in a subdirectory.

I send the command STAT subdir/file.

When I look at the TCP flow on wireshare what I get is:
MLST /subdir/file
Which is not really right if I don't have my FTP server set up for a virtual root directory.

Even if I try STAT ./subdir/file, it prepends another '/' and I wind up
with MLST /./subdir/file which is also not good.

Obviously I can work around this by implementing
CD subdir
STAT file
and it works just fine.

Thanks!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,271
Location:
Prague, Czechia

Re: 'STAT' command in winscp.com prepends '/'

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum