Topic "Exclude mask for files"

Author Message
ITTrucker

Guest


I'm trying to download a file from an ftp site. There are 4 files in the directory, 940data 940data.prior 943data 943data.prior

There are automated scripts that run on the server that once a successful download happens, it moves the data from the ###data files to the ###data.prior files, but it leaves the empty file names there. I'm trying to only download the original ###data files but the filemask either doesn't find anything, or gives me a log output of "Script: Can't get attributes of file '|'.

I've tried (without quotes) "get -filemask=943* | *.prior" and it gave me the file | error. Tried (without quotes) "get 943*|*.prior" and it said transfer complete but didn't actually copy anything and I tried a few other variations but I can't get the file to download.

If I use the GUI, and go into Find Files, if I put in the File mask: 943* | *.prior and click start, it finds the single file that I want to download, I just can't seem to make it work through a batch file, or the command line.

I'm using WinSCP Version 5.1.0 (Build 2625)

Thanks
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
I'm not sure if I understand.
Why don't you just download the "943data"?
get 943data

Anyway, you want to do:
get -filemask="943* | *.prior" *
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License