Visual glitches in new WinSCP 5.2 beta

Advertisement

Linda Kaioh
Joined:
Posts:
18

Visual glitches in new WinSCP 5.2 beta

Hi! WinSCP 5.2 beta at Windows XP SP3.

Bold gray line at tab bar dosn't look great.

I've found strange white background in file properties dialog. And strange file path label colors:

Same strange colors are in progress dialog:

When I move mouse pointer over path components at inactive panel, they are become same color as background. Previous version doesn't have this glitch.

Path components at active panel have same colors as before but also look awful.

I hope this will help you to make WinCSP look better.

<invalid links removed>

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Visual glitches in new WinSCP 5.2 beta

First, thanks for your post.

Linda Kaioh wrote:

Bold gray line at tab bar dosn't look great.
I'm aware of that. To be honest, it has a low priority as it looks like that only if you have visual themes turned off in Windows.

I've found strange white background in file properties dialog. And strange file path label colors:
White background: will take a look.
Path label: Fixed. https://winscp.net/tracker/show_bug.cgi?id=990

Same strange colors are in progress dialog:
The same. Fixed.

When I move mouse pointer over path components at inactive panel, they are become same color as background. Previous version doesn't have this glitch.


Path components at active panel have same colors as before but also look awful.
This is taken from your (non-standard theme-less) Windows color settings (Active title bar and Inactive title bar colors).
It do not think there was any change since the last version.
I admit the selection of hottrack color is not ideal (Though still, in most themes, it won't be the same as background color). I'll take a look at this.

Reply with quote

Linda Kaioh
Joined:
Posts:
18

Re: Visual glitches in new WinSCP 5.2 beta

martin wrote:

First, thanks for your post.

No problem ^^

martin wrote:

It do not think there was any change since the last version.

Hmmm... It's strange. I thought previous version use another colors at least for inactive panel. But I was wrong OO

Maybe you just need to use bold font instead of different color?

Reply with quote

Advertisement

You can post new topics in this forum