5.2 beta calls putty incorrectly

Advertisement

german guest
Guest

5.2 beta calls putty incorrectly

Hello,

I'm running a dedicated firewall system (ipfire) that uses non-default port 222 for it's own SSH in order to connect to external SSH servers by default port 22.

Now with WinSCP 5.2 beta the normal session works fine, only if I try "Open in PuTTY" command, the connection will be refused. PuTTY event log shows, that the port propagated is 22 rather then real session port 222 (found in PuTTY event log).

With WinSCP 5.1.4 there is no problem.

Would be nice, if this will be fixed in final 5.2

Best regards,
Johannes

Reply with quote

Advertisement

rowsdower
Guest

This is marked as fixed in bugtracker, but it is not fixed - KiTTY only tries using port 22.
If there is not a way to pass the port automatically to KiTTY, perhaps there should be a pattern added for port (such as !p), so you could specify:

path/to/kitty.exe !U@!@:!p

However I have tried these with no success (example port 2222):
path/to/kitty.exe !U@!@:2222
path/to/kitty.exe -P 2222 !U@!@

Both of these result in an error.
KiTTY users with non-standard ports will just have to use PuTTY until this is resolved (the port is passed properly to PuTTY).

Reply with quote

rowsdower
Guest

rowsdower wrote:

This is marked as fixed in bugtracker, but it is not fixed - KiTTY only tries using port 22.
If there is not a way to pass the port automatically to KiTTY, perhaps there should be a pattern added for port (such as !p), so you could specify:

path/to/kitty.exe !U@!@:!p

However I have tried these with no success (example port 2222):
path/to/kitty.exe !U@!@:2222
path/to/kitty.exe -P 2222 !U@!@

Both of these result in an error.
KiTTY users with non-standard ports will just have to use PuTTY until this is resolved (the port is passed properly to PuTTY).

I am using WinSCP 5.2.2 beta by the way.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

First, it works 100% if you allow WinSCP to interchange session settings with KiTTY using registry.

If you use portable KiTTY, then yes, WinSCP cannot pass port number on command-line. Anyway, the syntax with -P 2222 works:
path/to/kitty.exe -P 2222 !U@!@    

_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum