Topic "Configuration updates not saving after importing winscp.ini"

Author Message
itsgood
[View user's profile]

Joined: 2013-05-06
Posts: 2
Log debug 1 shows that my .ini file is saved at:
Configuration: C:\Program Files (x86)\WinSCP\WinSCP.ini

That file hasn't been updated since I imported the winscp.ini file from another computer. I can't switch back to the registry as my primary configuration (error 5).

How do I have WinSCP remember configuration changes that I make, post import?

Using WinSCP Version 5.1.4 (Build 3020) (OS 6.1.7601 Service Pack 1)
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
You probably do not have a write access to C:\Program Files (x86)\WinSCP\.
It would help, if you post a complete error, not just "error 5". But I suppose that WinSCP is able to copy configuration from INI file to registry, but needs to delete the INI file afterwards, what obviously fails (no permissions).

Some solutions:
- Delete the INI yourself (make back up). This would work providing the import to registry succeeded.
- Run WinSCP as administrator for the INI to registry switch.
- Use WinSCP 5.2 beta that allows importing configuration from INI file located anywhere:
https://winscp.net/eng/docs/config#import
_________________
Martin Prikryl
itsgood
[View user's profile]

Joined: 2013-05-06
Posts: 2
Thanks, Martin. I tried Beta 5.2 and that solved the problem. I have full admin rights to the folder, and I can edit the .ini file so it wasn't a write access issue. Regardless, the issue is fixed with 5.2. Thanks!! Keep up the great work with the product.

prikryl wrote:
You probably do not have a write access to C:\Program Files (x86)\WinSCP\.
It would help, if you post a complete error, not just "error 5". But I suppose that WinSCP is able to copy configuration from INI file to registry, but needs to delete the INI file afterwards, what obviously fails (no permissions).

Some solutions:
- Delete the INI yourself (make back up). This would work providing the import to registry succeeded.
- Run WinSCP as administrator for the INI to registry switch.
- Use WinSCP 5.2 beta that allows importing configuration from INI file located anywhere:
https://winscp.net/eng/docs/config#import
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
itsgood wrote:
Thanks, Martin. I tried Beta 5.2 and that solved the problem. I have full admin rights to the folder, and I can edit the .ini file so it wasn't a write access issue.

Right, but as you are using Windows 7, WinSCP runs probably in unpriviledged mode by default, no matter that your account is an admin. You may need to run it explicitly "as admin" to grant it access to system folders.
_________________
Martin Prikryl
JDJ

Guest


I've just had an identical problem with a newly installed copy of WinSCP on Windows 8.
Switching from .INI config to the Registry worked fine after running the program as Administrator.

It would be helpful if this could be documented somewhere!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
JDJ wrote:
It would be helpful if this could be documented somewhere!

What do you mean? To document fact that you cannot have a configuration file in a folder, where you do not have a write permissions to?
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License