Invalid access to memory when copying to new directory

Advertisement

eleigh
Joined:
Posts:
3
Location:
Cambridge, UK

Invalid access to memory when copying to new directory

This is a bug in versions 5.1.2 to 5.1.5. Easy to reproduce:

    Using Windows 7 x64
    SFTP connection to Unix (Ubuntu) server
    'Synchronize browsing' enabled
    Open a local directory that does not exist on remote server
    CONFIRM: Cannot open corresponding directory in the opposite panel. Do you want to try to create directory ...?
    Click Yes
    [Directory created]
    Copy a file into the new directory on the remote server
    COPY: Copy file ... to remote directory
    Click Copy with 'Transfer on background' checked
    ERROR: Error listing directory ... Invalid access to memory
    Click OK
    ERROR: Error listing directory ... Invalid access to memory
    Click OK
    ERROR: Copying files to remote side failed. Invalid pointer operation.
    Click OK
    RECURSIVE ERRORS [10-20]: Access violation at address 01829BE6 in module 'WinSCP.exe'. Read of address 00000018
    ERROR: A call to an OS function failed
    Click OK
    [WinSCP hangs]
    Only option then is to 'End Task'.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,271
Location:
Prague, Czechia

Re: Invalid access to memory when copying to new directory

Thanks for your report.
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum