Error trying to register dll for COM

Advertisement

bah12
Joined:
Posts:
2

Error trying to register dll for COM

I'd like to do some testing with a vbs script, however I'm having issues getting off the starting block. I downloaded the DLL (latest version todate 5.1.5 and same as my winscp install).

Per the instructions I try to run from the install folder C:\Program Files (x86)\WinSCP where the DLL is.
%WINDIR%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe WinSCPnet.dll /codebase /tlb    

First it gives and error WinSCPnet.dll cannot be found. Well that is probably just a bug in the instructions since the downloaded zip file only contains a file called winscp.dll (no net in the file name).

So I modifed the code to read.
%WINDIR%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe WinSCP.dll /codebase /tlb    

This produced the error.

Microsoft (R) .NET Framework Assembly Registration Utility 4.0.30319.1
Copyright (C) Microsoft Corporation 1998-2004.  All rights reserved.

RegAsm : error RA0000 : Could not load file or assembly 'file:///C:\Program File
s (x86)\WinSCP\WinSCP.dll' or one of its dependencies. Operation is not supporte
d. (Exception from HRESULT: 0x80131515)    

Am I missing something here??? This should be the easy part LOL.

FYI Tried renaming the dll to winscpnet.dll, but same error.

Reply with quote

Advertisement

You can post new topics in this forum