Synchronization error occurred while setting the permissions

Advertisement

mabc
Joined:
Posts:
7

Synchronization error occurred while setting the permissions

Hello,

I am using the below command to synchronize files; however I get the following error: upload of file XXX was successful but error occurred while setting the permissions and/or timestamp. I added -nopermissions and -nopreservetime in hopes that this would resolve the issue but no such luck. I appreciate any and all assistance.

synchronize remote -nopermissions -nopreservetime -delete C:\productPDFs\ /productInfo/

I'm running WinSCP 5.1.5

Thank you.

Reply with quote

Advertisement

mabc
Joined:
Posts:
7

Martin,

Thank you for your reply! How do I turn off the Modification timestamp setting given that I am using a command to synchronize two directories (I don't see a switch listed for this here: https://winscp.net/eng/docs/scriptcommand_synchronize)? If I disable the timestamp check, what criteria is used to synchronize the remote directory? Timestamp seems like a very important piece of criteria for synchronization purposes.

Your help is greatly appreciated!

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Sorry, I should have read your question more carefully.
With synchronization, you are out of luck. You can hardly synchronize files, when you do not have permissions to update theirs timestamps.
You would have to synchronize them based on file size, what is not really reliable.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum