Topic "Copy (and not move) by default when dragging out"

Author Message
P. Grande

Guest


(Using Explorer-like Interface)

The Windows(tm) standard states that when dragging a file from one DEVICE to another (not between FOLDERS within the same DEVICE) that file must be COPIED if no modifier key is pressed (CAPS).

Since the remote SCP/SFTP server is certainly not within the bounds of our local drive, the COPY option should be used by default, as it is the default when dragging TO the WinSCP window.
(I don't see the point of moving, though.. you can always delete the remote/local item after copying and retry the transfer if interrupted without headaches).

That default annoying behaviour is even worst when dealing with folders.

Furthermore, the mouse overlay icon when dragging out of WinSCP shows a plus [+] sign wrongly stating that you are copying....

I think i should file this as a bug report instead of a feat. req..

Martin, please, correct this one.

P. Grande
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
P. Grande wrote:
The Windows(tm) standard states that when dragging a file from one DEVICE to another (not between FOLDERS within the same DEVICE) that file must be COPIED if no modifier key is pressed (CAPS).

Well, that perfectly true and nice to have. But it is difficult to enforce. You should read F.A.Q. on this topic.

Quote:
Furthermore, the mouse overlay icon when dragging out of WinSCP shows a plus [+] sign wrongly stating that you are copying....

This is wrong. I have noticed it also on some slower machines and I have tried to fix it. Wait for the next release. BTW: I suppose that this happens when you have WinSCP drag&drop shell extension installed.
_________________
Martin Prikryl
P. Grande

Guest


prikryl wrote:
P. Grande wrote:
The Windows(tm) standard states that when dragging a file from one DEVICE to another (not between FOLDERS within the same DEVICE) that file must be COPIED if no modifier key is pressed (CAPS).

Well, that perfectly true and nice to have. But it is difficult to enforce. You should read F.A.Q. on this topic.


I had already read the FAQ before posting.
From the FAQ:
prikryl wrote:
Only thing that can WinSCP potentially do (in fact it optionaly did it before 3.5.5) is to disable move operation at all. It would force to use "copy", because there would be no other option.
However WinSCP drag&drop shell extension uses kind of hack to force the "copy" to be a default. So if you install and enable (in Preferences) it, the "copy" should be a default.


I cannot find a way to forcibly disable moving.
When left dropping, move is the default operation; when right dropping, a popup menu will let me choose between "Copy here", "Move here" (the default one), and "Cancel".
Cancelling or clicking out of the popup menu brings up the DRAGEXT_TARGET_UNKNOWN MsgBox. (Which, btw, is quite annoying. There should be an option to turn it off).

And for the difficultness...
I know it can be done (e.g. right drop a message from Outlook Express to an Explorer window, or right drop a file from Total Commander, etc..)
But i don't know how hard it can be.
Anyway, if there is some hidden option to disable moving, i'm done.
<dumb>Help me locate it, please</dumb>

prikryl wrote:
P. Grande wrote:
Furthermore, the mouse overlay icon when dragging out of WinSCP shows a plus [+] sign wrongly stating that you are copying....

This is wrong. I have noticed it also on some slower machines and I have tried to fix it. Wait for the next release. BTW: I suppose that this happens when you have WinSCP drag&drop shell extension installed.


DragShell Version 1.0.1.29
WinSCP 3.6 (Build 216)
SO: Windows 2000 Prof. SP4 Spanish
CPU: Athlon XP 1700+

The [+] icon keeps on showing when dragging, and this machine itself yields it is not slow, nor slower Wink

Thanks again Martin.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
P. Grande wrote:
I cannot find a way to forcibly disable moving.

The option is available only when you are not using the extension, because I've hoped that with the extension, it will be working. I have made some fix in the new version (3.6, released yesterday). Check if it helps you. And, please, let me know. If it does not I'll add the option to "disable moving" even with the extension.

Quote:
When left dropping, move is the default operation; when right dropping, a popup menu will let me choose between "Copy here", "Move here" (the default one), and "Cancel".
Cancelling or clicking out of the popup menu brings up the DRAGEXT_TARGET_UNKNOWN MsgBox. (Which, btw, is quite annoying. There should be an option to turn it off).

It is not possible to turn it off. Or at least I do not know how to do it.

Quote:
And for the difficultness...
I know it can be done (e.g. right drop a message from Outlook Express to an Explorer window, or right drop a file from Total Commander, etc..)
But i don't know how hard it can be.

Right drop from Total Commander: You are copying local file, so the drop can be handled by target application, which displays the menu, so it has everything under control. It is the same case as right dropping from the right panel to the left inside WinSCP. The "Abort" works as well.

Right drop from Outlook Express: It works because of tight integration between Microsoft products. Possibly I can integrate WinSCP as well, but I do not know how.

Looking forward for your opinion/experiences.
_________________
Martin Prikryl
P.Grande

Guest


prikryl wrote:

The option is available only when you are not using the extension, because I've hoped that with the extension, it will be working. I have made some fix in the new version (3.6, released yesterday). Check if it helps you. And, please, let me know. If it does not I'll add the option to "disable moving" even with the extension.


The new version of the shell extension (1.1.0.33) won't help.

prikryl wrote:
It is not possible to turn it off. Or at least I do not know how to do it.


OK, in the meantime i've disabled the shell extension for everyday work. An accidental unsuccesful moving operation could get me fired Wink

I'd really like to aid you, and i'm trying to be as helpful as i can.
Lately i've been digging on the internet for some code which could be useful, but haven't find anything explicit as of now... besides i'm not in Borland's mood, and cannot take more Delphi than those blurry hidden memories of Pascal code from the old college days. Sorry.

Some URLs:

<invalid hyperlink removed by admin>
http://www.unitoops.com/uoole/examples/
http://www.paranoia.clara.net/articles/using_delphi_shell_controls.html
<invalid hyperlink removed by admin>
<invalid hyperlink removed by admin>
<invalid hyperlink removed by admin>

Hope that helps...
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
P.Grande wrote:
The new version of the shell extension (1.1.0.33) won't help.

Problem was with WinSCP, not with the extension. But I suppose that you were trying it with 3.6 as well, were you?

Thanks for the links.
_________________
Martin Prikryl
P.Grande

Guest


Version 3.6.0.217
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Unfortunatelly the links you've posted did not helped. In fact I was not expecting it, I think I have read enough on the topic already to know that the problem is unsolvable without rewriting the program significantly.

So I have added the option to disable move to make copy default even for the extension. And I have removed the trick that makes copy default, which showed not to be reliable (at least for you).

Please wait the next release (this week).
_________________
Martin Prikryl
bizarrojack
[View user's profile]
Donor
Joined: 2004-05-11
Posts: 5
Quote:
If I drag with the ctrl key held, I get a cursor in the drop folder with a "+" sign displayed, and I am prompted by winscp to copy the file.

If I drag with the shift key held, I get a cursor with no + sign, and I am prompted by winscp to move the file.

If I drag with no keys held, I get a cursor with a + sign (like when holding ctrl) BUT then I am prompted by winscp to move the file.

If I use the right mouse button to drag a file from a server window to a windows explorer folder or desktop, windows gives me a menu: Copy Here, Move Here (bold), Cancel. In previous versions of winscp, i would be prompted to move no matter which of the first two choices I use. Using version 3.6 and win2k though, that seems to be fixed. This paragraph is really just historical trivia, because as of the new version it is not a problem.

Any idea why dragging would give a cursor with a + sign (I consider this a false indicator that a file will be copied without deletion), but then winscp would prompt for a move?



I had posted over in another thread before finding this one. I just figured I'd annotate here that I have the same problem. I am on a slow machine though and it has been this way for a while for me. I dont need anything that you havent already commented on here.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
bizarrojack wrote:
I had posted over in another thread before finding this one. I just figured I'd annotate here that I have the same problem. I am on a slow machine though and it has been this way for a while for me. I dont need anything that you havent already commented on here.

The next version will have option (turned on by default) to allow only copy operation when downloading outside of WinSCP. It will hopefully solve all the problems above.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License