Turn off Optimize connection buffer size

Advertisement

kdejarnet
Joined:
Posts:
3
Location:
Austin, TX

Turn off Optimize connection buffer size

Is there a way to do this in the script? I tried using "option optimize connection buffer size off" but this is throwing an error.

Thanks.

Reply with quote

Advertisement

kdejarnet
Joined:
Posts:
3
Location:
Austin, TX

Re: Turn off Optimize connection buffer size

martin wrote:


I've been trying to get this to work in a SSIS 2005 Execute Process Task but keep getting the message "Unknown command -rawsettings"

I'm using it as the first line of my script like so: -rawsettings SendBuf=0

Is there a different way I should be using this?

Thanks,

Keith

Reply with quote

sugaz007
Guest

-rawsettings getting error

I have this below statement in ssis script task which calls winscp and passes below command

open sftp://<<User Name>>:<<Password>>@<<Domain>>:21 -rawsettings SendBuf=0 -hostkey="<<hostkey>>"

Host is not communicating for more than 15 seconds. Still waiting...
Note: If the problem repeats, try turning off 'optimize connection buffer size'

Please help

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: -rawsettings getting error

sugaz007 wrote:

I have this below statement in ssis script task which calls winscp and passes below command

open sftp://<<User Name>>:<<Password>>@<<Domain>>:21 -rawsettings SendBuf=0 -hostkey="<<hostkey>>"

Host is not communicating for more than 15 seconds. Still waiting...
Note: If the problem repeats, try turning off 'optimize connection buffer size'
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

_________________
Martin Prikryl

Reply with quote

samr
Joined:
Posts:
4

For some reason, the site I connect to doesn't work well with the "Optimize connection buffer size" enabled, and whenever I had that on while downloading files larger than a few megabytes, I'd get this error: Server unexpectedly closed network connection.

Fortunately, I found how to turn it off and (in the GUI version at least) all my transfers are successful. On the contrary, in batch mode from a script file, even after setting "-rawsettings SendBuf=0" appended to the open command, the connection will "unexpectedly close" on files larger than a few megabytes.

Does SendBuf=0 completely turn off the feature as the GUI checkbox does?

Thank you.

Reply with quote

SimonBu
Guest

same Problem

Hi prikryl,

I have the same problem... but in my case turning off the SendBuf and SSHSimple doesn´t work ;-(

I have attached my Log File ...


Thanks for your Support


Simon
  • log.txt (10.5 KB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: same Problem

SimonBu wrote:

I have the same problem... but in my case turning off the SendBuf and SSHSimple doesn´t work ;-(

I have attached my Log File ...
Please attach a complete log file.

Reply with quote

Advertisement

You can post new topics in this forum