[Bug] Access violation error after OS sleep

Advertisement

Jammer
Guest

[Bug] Access violation error after OS sleep

Hi there,

First of all, great product, been using it for years, thank you very much for creating something this good.

Secondly, a slight annoying bug (doesn't happen always):
If you have WinSCP connected to a SCP server, with keep-alives, and then put your computer to sleep, wait 10 or so minutes, and then bring it back up, wait a 10 or so minutes, WinSCP usually starts throwing Access violation exceptions (probably because the socket goes missing).


Thanks!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: [Bug] Access violation error after OS sleep

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

ADTC
Joined:
Posts:
18

Wake up from sleep or hibernate produces this error

I'm able to consistently reproduce this problem. If WinSCP is connected to a server and my computer goes into sleep or hibernate, when I resume the computer and switch to WinSCP, it starts throwing this unending foray of 'access violation' messages. I am forced to find the WinSCP process in Task Manager and end it. There are two messages that repeatedly pop-up as several numerous copies.

Screenshots (taken with some pain) are attached. I will send you an email so that you can send me a debug version.

Description: Access violation at address 0080A4D2 in module 'WinSCP.exe'. Read of address 00000000

WinSCP2.png

Description: System Error. Code: 87.
The parameter is incorrect

WinSCP1.png

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Wake up from sleep or hibernate produces this error

ADTC wrote:

I'm able to consistently reproduce this problem. If WinSCP is connected to a server and my computer goes into sleep or hibernate, when I resume the computer and switch to WinSCP, it starts throwing this unending foray of 'access violation' messages. I am forced to find the WinSCP process in Task Manager and end it. There are two messages that repeatedly pop-up as several numerous copies.
Thanks for your report.
What version of WinSCP are you using?
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
_________________
Martin Prikryl

Reply with quote

ADTC
Joined:
Posts:
18

Sorry Martin, it looks like this bug had been fixed in a later version (I updated to 5.1.7). Silly me, I didn't update WinSCP [Talking about which, you might want to consider an automatic update solution, or at least download and launch the installer right from the 'Check for updates' function.]

I'm not a 100% sure it's fixed, but if I get it again, I'll report it (after updating and reproducing the error :) ).

Reply with quote

Advertisement

You can post new topics in this forum