End of line encoding problems

Advertisement

mrutledge
Guest

End of line encoding problems

I have a problem that I don't know how to tackle. We have files that get sftpd over to a client's windows computer. He actually initiates the pull. They are complaining that the LF are not in the file. I downloaded winscp and tried this myself, setting the Environment setting to CRLF. When I open winscp and log in, I can see the source file on the right side. If I double-click and copy/paste the contents into Notepad++ I can see the CRLF at the end of each sentance. If I move the file to my desktop I loose them.

I tried setting the transfer mode to Binary with same results. Can anyone suggest something else to try?

Thanks,
Rut

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: End of line encoding problems

I suppose that your remote files actually lack the LF's. When downloading files to local editor, WinSCP by default uses text/ascii transfer mode, thus adding the LF. While for regular download, it does not (what you have enforced anyway by using binary protocol). So you probably want to actually enforce using text/ascii mode. Or altering generation of the remote files to have them include the LF's.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum