Problems with SFTP if password contains non ASCII characters

Advertisement

jagger
Joined:
Posts:
2
Location:
Germany

Problems with SFTP if password contains non ASCII characters

I am using the latest version of WinSCP (verson 5.1.7 build 3446).
There is a problem with logging in via SFTP if password contains non ASCII characters.
In my case it is "" (o umlaut). Changing the password to less strong without non ASCII characters solved the problem but I think you should have a look on this issue.

I have found an older post in which the guy had a pound sign in his password. The post is from 2011 and it looks like this problem has not been solved for a long long time then.

https://winscp.net/forum/viewtopic.php?t=10392

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problems with SFTP if password contains non ASCII characters

Any chance of getting a test account on your server? On the servers I've tried this with, PuTTY does not work either with non-ascii passwords.

Reply with quote

jagger
Joined:
Posts:
2
Location:
Germany

Re: Problems with SFTP if password contains non ASCII characters

martin wrote:

Any chance of getting a test account on your server? On the servers I've tried this with, PuTTY does not work either with non-ascii passwords.

Hi, unfortunately the server does not belong to me. Do you have the terminal coding in PuTTy set to UTF-8?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problems with SFTP if password contains non ASCII characters

jagger wrote:

Do you have the terminal coding in PuTTy set to UTF-8?
Yes, I have.

What is your SSH/SFTP server?

Reply with quote

Advertisement

You can post new topics in this forum