set times: Operation not permitted

Advertisement

ooglek
Joined:
Posts:
3

set times: Operation not permitted

I've got group permissions on the remote end of rwxrwsr-x for .
The user I'm logged in as is part of the group that owns the file:
-rw-rw-r-- 1 root webadmin 4250 May 12 13:26 Application.cfm

(yes, I will make sure its not owned by root soon)

The file is successfully uploaded to the site, but I get a "set times: Operation not permitted" error, even though the file is transferred successfully.

I know if I uncheck "Preserve Timestamp" that this will resolve the issue; I'm more curious about why I cannot set times on a file I can write to, but I can overwrite the file.

Thanks

Last edited by ooglek on 2004-05-13 16:47; edited 1 time in total

Reply with quote

Advertisement

ooglek
Joined:
Posts:
3

Another log where the transfer is successful

To rephrase -- I've read the FAQ on this issue; however the FAQ does not describe why this occurs, nor why it has not been resolved since the unix file system allows the user who is in the group to modify the file timestamp using "touch" available on all modern Unix OSes. I wanted to discuss WHY this occurs, and why it cannot be fixed, or if it can be fixed.

Last edited by ooglek on 2004-05-13 16:49; edited 1 time in total

Reply with quote

ooglek
Joined:
Posts:
3

Unsetting preserve timestamp

Thanks for your reply!!!

As you can see in original post, I know from the FAQ that unsetting preserve timestamp will resolve that issue.

My question is WHY can WinSCP not modify the timestamp on a file when the file permissions allow me to use "touch" to modify the timestamp? Is it because the method WinSCP uses to modify the timestamp does not respect unix file system permissions? Is it because of something else? Is it fixable? Resolvable? This has been happening since 2002 -- why hasn't someone fixed it if it is fixable? It seems that this could be implemented on all Unix OSes fairly easily, but I don't know the code either.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Unsetting preserve timestamp

ooglek wrote:

As you can see in my post, I know that unsetting preserve timestamp will resolve that issue.
I apologise, I was not reading it carefully enough.

My question is WHY can WinSCP not modify the timestamp on a file when the file permissions allow me to use "touch" to modify the timestamp? Is it because the method WinSCP uses to modify the timestamp does not respect unix file system permissions? Is it because of something else? Is it fixable? Resolvable? This has been happening since 2002 -- why hasn't someone fixed it if it is fixable? Obviously on all Unix OSes it is easily done.
IFAIK It is not problem of WinSCP. Try any other SCP client, and I believe that you'll see the same results. It is the way the SCP servers are coded.
_________________
Martin Prikryl

Reply with quote

karci
Guest

Re: this is utter bullshit

bullshit wrote:

This works in linux just wonderfully. Pleaso go home and fix yer winscpcrap...

I experience the same behaviour directly in a Linux shell.
When I "touch" a file I have group access to, it works fine (and its timestamp changes to the current system time).
However, as soon as I want to set a given timestamp to this file (using touch -t), I get "Operation not permitted", although the file is writable for me and I can even "touch" it without the -t flag.

So I would conclude that Linux requires that _you own_ the file for which you want to set a given timestamp, having just write access is not enough.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: this is utter bullshit

karci wrote:

So I would conclude that Linux requires that _you own_ the file for which you want to set a given timestamp, having just write access is not enough.
Correct.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum