Private key format reported as invalid

Advertisement

bobes
Guest

Private key format reported as invalid

Hello,

Private keys in proper PPK putty format are reported as invalid when entered through SSH -> Authentication -> Private Key File dialog. Not sure why WinSCP is not able to recognize this format, I have no problem with Putty 0.63 and I am almost sure older version of WinSCP got no problem as well.

Reply with quote

Advertisement

bobes
Guest

Re: Private key format reported as invalid

Just to replicate the problem:

WinSCP version 5.2.5, Windows 7 x64

Key format: PPK
PuTTY-User-Key-File-2: ssh-dss
Encryption: aes256-cbc

After pressing Ignore and saving the config, login procedure using the secret key works with no problem.

Description: Dialog window with error

ppk-error.gif

Reply with quote

Guest

The error is still present via command line, I use a batch like this:

start winscp.exe sftp://ubuntu@X.Y.W.Z /privatekey=mykey.ppk

response

<invalid link removed>

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Anonymous wrote:

The error is still present via command line, I use a batch like this:

start winscp.exe sftp://ubuntu@X.Y.W.Z /privatekey=mykey.ppk

response

<invalid link removed>
That's a different error. Most likely the private key file does not exist in the path given. Are you sure that you start WinSCP in the folder, where the key is stored? Have you tried using full path to the key?

Reply with quote

Guest

No, the file is present, I opened a CMD in the directory winscp and in the same directory there is also the key, but for some reason it does not find it.

Today I made other tests. The strange thing is that if I copy the whole dir to another PC it works, so at this point there must be something strange in my PC, but if I open the program and load the key from the GUI it works.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

but if I open the program and load the key from the GUI it works.
What is a full path that GUI shows when you select the key? Can you post a session log file showing authentication after you select key in GUI?
_________________
Martin Prikryl

Reply with quote

Guest

martin wrote:

but if I open the program and load the key from the GUI it works.
What is a full path that GUI shows when you select the key? Can you post a session log file showing authentication after you select key in GUI?

Confirming that I'm also seeing this.

If I click on "Ignore", the key is accepted and authenticates with no issue.

The error is only when selecting the key initially.

This is in 5.5.1.b3970

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Confirming that I'm also seeing this.

If I click on "Ignore", the key is accepted and authenticates with no issue.

The error is only when selecting the key initially.

This is in 5.5.1.b3970
The same answer:
What is a full path that GUI shows when you select the key? Can you post a session log file showing authentication after you select key in GUI?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum