No session log

Advertisement

Oleg
Guest

No session log

Hello,
I'm using WinSCP rev. 5.1.7, everything looked normal and about a week or so ago the log is not generated and I did not even changed a single letter in the script.
Here is the line from the script:
winscp.com /script=c:\Test\sftptransfer.txt /privatekey=c:\Test\keyfile.ppk /log=c:\Test\session.log

I tried to move the log part to different places in the line - same result.
The script itself (windows batch script, creates a zip file, encrypts it with PGP and sends to a recipient using WinSCP, runs on Windows Server 2008 R2 Enterprise) writes a few lines into its own log, so it looks clear permission-wise.
No WinSCP log.
Appreciate in advance,
Oleg

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,459
Location:
Prague, Czechia

Re: No session log

Your syntax is correct (for the log). Does your batch file log to the same folder (c:\test)? I assume the script itself (file upload) works.

As aside note: You should use -privatekey switch of open command from your script file, not /privatekey command-line parameter.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum