Topic "scheduled script not using passphrase"

Author Message
[View user's profile]

Joined: 2013-12-13
Posts: 1
Location: Ireland
I am using WINSCP 5.1.8, build 3799. I have written a little script to transfer some files to another site. When I run this manually , it works juts fine.
But when I run it through as a task in task Scheduler in fails.

My server is windows 2008 datacentre r2.I have compared the logs from both attempts and I can see that on the manual attempt, pageant is called with the passphrase, but in the scheduled attempt it isn't called.

The protocol is SFTP, my script is below

option batch abort
option confirm off
open zinmobi
put c:\Zinmobi_Daily\*.csv

Here is the command line

"C:\Program Files (x86)\WinSCP\" /script=c:\script\ZinmobiSFTP.txt
move c:\Zinmobi_Daily\*.csv C:\Zinmobi_Daily\Archive
ZinmobiManual.log (10.12 KB) [Download]

Description: This is the log of the transfer that worked

ZinmobiScheduled.log (4.52 KB) [Download]

Description: This is the scheduled transfer that failed

[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26911
Location: Prague, Czechia
You cannot access Pageant running in a different Windows session.

See also
Martin Prikryl

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License