Topic "suddenly fail to start winscp"

Author Message
adnanrapid

Guest


i am using version 5.1.7, updated it today to 5.5.1, but same error still alive.(this error started before updating)

this is a production issue, my service uploads and gets files from ftp up to 2 or 3 times a day.
i encouter with error that says:

WinSCP process terminated with exit code 3 and output "", without responding (response log file C:\Windows\TEMP\wscp0D74.03C7E714.tmp was not created). This could indicate lack of write permissions to the log folder or problems starting WinSCP itself.

i just checked the permissions and it looks correct.
i tried to change the storage location in the tools window, but it seems like the program stuck on this particular windows temp folder.

Please assist, how to solve this issue.

Regards,
Adnan - Rapid Image.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
You are probably a victim of this bug:
https://winscp.net/tracker/show_bug.cgi?id=996

Please upgrade WinSCP AND restart your server.
adnanrapid

Guest


thank you very much, is working.
wile135

Guest


martin wrote:
You are probably a victim of this bug:
https://winscp.net/tracker/show_bug.cgi?id=996

Please upgrade WinSCP AND restart your server.




Hi,
I also have the same problem.Because the server has another system on it,so i can't rstart it.
Can i just upgrage WinSCP to 5.5.1??

Regards,
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
wile135 wrote:
I also have the same problem.Because the server has another system on it,so i can't rstart it.
Can i just upgrage WinSCP to 5.5.1??

No, it won't help.
Quote:
While the fixed versions no longer gradually exhaust system resources, they cannot recover resources exhausted by previous buggy versions. So it's still necessary to restart affected machine to recover the system.

Quote from https://winscp.net/tracker/show_bug.cgi?id=996#c19
_________________
Martin Prikryl
naren54783
[View user's profile]

Joined: 2014-12-22
Posts: 6
Location: Narendra Patel
martin wrote:
wile135 wrote:
I also have the same problem.Because the server has another system on it,so i can't rstart it.
Can i just upgrage WinSCP to 5.5.1??

No, it won't help.
Quote:
While the fixed versions no longer gradually exhaust system resources, they cannot recover resources exhausted by previous buggy versions. So it's still necessary to restart affected machine to recover the system.

Quote from https://winscp.net/tracker/show_bug.cgi?id=996#c19



Even simply restart resolve the issue and then why to upgrade WinSCP version?
Do we have any permanent solution for this issue?
if yes, then which version of winSCP we should use?

But we can't restart production servers each time this issue occurs.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
naren54783 wrote:
Even simply restart resolve the issue and then why to upgrade WinSCP version?
Do we have any permanent solution for this issue?
if yes, then which version of winSCP we should use?

The permanent solution is to upgrade (and restart). With newer versions of WinSCP, the error won't happen anymore. Always the latest version of WinSCP.
PW
[View user's profile]

Joined: 2017-01-03
Posts: 2
martin wrote:
naren54783 wrote:
Even simply restart resolve the issue and then why to upgrade WinSCP version?
Do we have any permanent solution for this issue?
if yes, then which version of winSCP we should use?

The permanent solution is to upgrade (and restart). With newer versions of WinSCP, the error won't happen anymore. Always the latest version of WinSCP.


Hi. This is unfortunately not correct. I restarted the server after update WinSCP to 576 (approximately at the time of your post 2015) and the problem did not disappeared.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
PW wrote:
Hi. This is unfortunately not correct. I restarted the server after update WinSCP to 576 (approximately at the time of your post 2015) and the problem did not disappeared.

Please attach a full debug log file showing the problem (using the latest version of WinSCP, not the 5.7.6).

To generate the debug log file, set Session.DebugLogPath. Submit the log with your post as an attachment. If you do not want to post the log publicly, you can mark the attachment as private.
PW
[View user's profile]

Joined: 2017-01-03
Posts: 2
martin wrote:

Please attach a full debug log file showing the problem (using the latest version of WinSCP, not the 5.7.6).

To generate the debug log file, set Session.DebugLogPath. Submit the log with your post as an attachment. If you do not want to post the log publicly, you can mark the attachment as private.


Here is the debug log file.
WinSCP-debug_170115_0630_CLEAN.log (6.93 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License