Topic "ACCESS DENIED on system folder whilst trying to sync"

Author Message
jimimaseye
[View user's profile]

Joined: 2014-03-12
Posts: 2
Environment:

System: Win server 2008 R2 uploading to NAS storage
Session Environment: Connection protocol: SFTP.
Synchronize: MIRROR, to REMOTE destination, check by Modification Time.

Server 'Administrator' "documents" folder contains 2x user created folders, and 3 'hidden' system shortcuts "My Pictures", "My Music" and "My Videos"

After connection, Im going in to the 'DOCUMENTS' folder of my server adminstrator to do an upload mirror.

Initially using version 4.37, running a sycronise (mirror to remote) all 5 folders were created on the remote system. ie, I received the 2x user folders (and their contents) plus the 3 hidden "My..." folders albeit empty. (remember on the local drive these folders are via a Shortcut). - these just appeared on the remote as 3 standard empty folders (called 'My Videos' etc).

However, with the latest v5.51 I cant even run the syncronise comparison because I get the error:
"System Error. Code: 5.
Access is denied"

while trying to access My Videos (and I suppose it would on the other folders too but it forces an Abort)

(screenshot attached)

I sort of understand it because even in Windows explorer I get the same error due to the shortcut pointing to a non-accessible folder (although I dont understand why). BUT...... version 4.37 does not react this way and simply sees the non-acessable folder as empty and has created the empty folders on the remote. In any case, coming across a non-accessable subfolder shouldnt stop the comparison from running outright (thus preventing other comparisons being made for other folders).

What am i doing wrong? (I have tried unchecking the 'Resolve symbolic links' in the session Environment - Directories' settings). Curently, with 5.51 I cannot go to my DOCUMENTS folder and do a straight forward SYNCRONISE to remote compare. (And cant go back to 437 because of timestamp problems and inconsistancies).

Appreciate your help

Thanks
screenshot.jpg (145.1 KB) [Download]

Description: screenshot of werror

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Old versions of WinSCP incorrectly silently ignored failures to read local inaccessible directories.

This has been changed in 5.2:
https://winscp.net/tracker/show_bug.cgi?id=952

You need to explicitly exclude those folders from synchronization using file mask.
_________________
Martin Prikryl
jimimaseye
[View user's profile]

Joined: 2014-03-12
Posts: 2
Thank you Martin. I will adjust accordingly. Many thanks.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License