Synchronize command downloads all the files again, DST?

Advertisement

3K
Donor
Joined:
Posts:
34
Location:
Geneva

Synchronize command downloads all the files again, DST?

Hi,

I noticed yesterday, 31 March 2014, when I run my batch command below, it downloaded all the files again. Perhaps, the document's timestamps were shifted because of Daylight Saving Time? What is the solution or command to avoid downloading all the files?

option batch continue
option confirm off
option reconnecttime 2
open ftp://....
option transfer automatic
synchronize -mirror local "C:\doccuments" "/server/documents"
close
exit

I'm using Winscp552.

Thanks.

Reply with quote

Advertisement

3K
Donor
Joined:
Posts:
34
Location:
Geneva

Thanks prikryl,

I read the Synchronization mode below which may be used in our case but this is not completely correct - to update the timestamp of the target file without comparing the file size. My suggestion is to initially compare the file size and if they are the same, go and update the timestamp. If not, the source file means it's updated and should replace the target file instead.

With Synchronize timestamps mode, the timestamps of target files are updated to match timestamps of source files. It will not do any transfers, nor delete anything. Simply, whenever it finds the same file in both directories it updates the timestamp of target file to match the one of source file. In Both mode, it always updates the older timestamp. The mode is available with SFTP protocol only.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

3K wrote:

I read the Synchronization mode below which may be used in our case but this is not completely correct - to update the timestamp of the target file without comparing the file size. My suggestion is to initially compare the file size and if they are the same, go and update the timestamp. If not, the source file means it's updated and should replace the target file instead.
The you select the Synchronize timestamp mode, you will have an option Same size only.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

martin wrote:

3K wrote:

I read the Synchronization mode below which may be used in our case but this is not completely correct - to update the timestamp of the target file without comparing the file size. My suggestion is to initially compare the file size and if they are the same, go and update the timestamp. If not, the source file means it's updated and should replace the target file instead.
The you select the Synchronize timestamp mode, you will have an option Same size only.

Though the Synchronize timestamp mode is not really a solution, it's the last resort, when the server is buggy.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum