GSSAPI authentication only works for first session

Advertisement

riskable
Joined:
Posts:
1
Location:
Jacksonville, FL

GSSAPI authentication only works for first session

When performing GSSAPI/Kerberos authentication only the first session will connect without asking for a password. Subsequent sessions open to the same server will ask for a password.

To reproduce:

1) Connect to an SFTP server using GSSAPI authentication (it should not ask for your password).
2) Open a new session to the same server (ensure GSSAPI authentication is enabled). It will ask you for your password.

With "debug 2" logging enabled the (relevant) error in the second session is thus:

. 2014-04-08 10:06:19.626 GSSAPI authentication initialisation failed
. 2014-04-08 10:06:19.626 Unspecified GSS failure.  Minor code may provide more information Matching credential not found    

Note that absolutely nothing was changed in the session settings between opening the first and second session. The entire (sanitized) log is attached
  • myuser@someserver.log (49.86 KB, Private file)
Description: Debug 2 log of both sessions

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: GSSAPI authentication only works for first session

Does this happen for second parallel connection only or even for second consecutive? I assume that restarting WinSCP helps, right?

Reply with quote

Advertisement

You can post new topics in this forum