Maintaining file ownership while copying/transferring file

Advertisement

Bill
Joined:
Posts:
1

Maintaining file ownership while copying/transferring file

Can someone out there please help me with this problem? When I transfer a file from the Remote server to the Local server the ownership of the file changes and is causing a lot of problems. I have the properties set as: Owner - r w & Group - r w, the owner of the file on the remote side is 15197, but once I transfer the file over the owner is my username. How can I maintain the owner as 15197? I am using V3.1 in sftp mode.

btw I have tried this in scp mode also.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Re: Maintaining file ownership while copying/transferring file

Do I understand that you want to maintain file ownership when transfering file from your server to your local machine? What for? Do you have the same user base on the server and the local machine? What is your server, is it Windows server?

Anyway, WinSCP cannot do this. Noone has ever wanted such feature.
_________________
Martin Prikryl

Reply with quote

hshah
Guest

Re: Maintaining file ownership while copying/transferring fi

I have the same need. Remote host is Unix and local machine is Windows XP. When I copy files from the remote to local machine, I would like to preserve the owner. Please do let me know if between then and now, if this feature was added or it is possible with some custom command.

Thank you


martin wrote:

Do I understand that you want to maintain file ownership when transfering file from your server to your local machine? What for? Do you have the same user base on the server and the local machine? What is your server, is it Windows server?

Anyway, WinSCP cannot do this. Noone has ever wanted such feature.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Re: Maintaining file ownership while copying/transferring fi

hshah wrote:

I have the same need. Remote host is Unix and local machine is Windows XP. When I copy files from the remote to local machine, I would like to preserve the owner. Please do let me know if between then and now, if this feature was added or it is possible with some custom command.
This has always worked. Providing you disable resume support.
_________________
Martin Prikryl

Reply with quote

hshah
Guest

Re: Maintaining file ownership while copying/transferring fi

Thank you for your response. However, I am not sure if I understood your response.

In preferences --> Transfer --> Resume: I selected "Disable". Then I tried copying a file from the unix remote host to my local machine. The owner on the remote host is someone other than my username. After copying it to my local machine (Win XP), the owner of the file as seen in windows explorer is showing up as my username. I want it to be the owner as it shows up on the remote host.

Did I miss anything?

Thanks again for your support.

martin wrote:

hshah wrote:

I have the same need. Remote host is Unix and local machine is Windows XP. When I copy files from the remote to local machine, I would like to preserve the owner. Please do let me know if between then and now, if this feature was added or it is possible with some custom command.
This has always worked. Providing you disable resume support.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Re: Maintaining file ownership while copying/transferring fi

hshah wrote:

Thank you for your response. However, I am not sure if I understood your response.

In preferences --> Transfer --> Resume: I selected "Disable". Then I tried copying a file from the unix remote host to my local machine. The owner on the remote host is someone other than my username. After copying it to my local machine (Win XP), the owner of the file as seen in windows explorer is showing up as my username. I want it to be the owner as it shows up on the remote host.
What is your SSH/SFTP server software?
_________________
Martin Prikryl

Reply with quote

Guest

Re: Maintaining file ownership while copying/transferring fi

martin wrote:

hshah wrote:

Thank you for your response. However, I am not sure if I understood your response.

In preferences --> Transfer --> Resume: I selected "Disable". Then I tried copying a file from the unix remote host to my local machine. The owner on the remote host is someone other than my username. After copying it to my local machine (Win XP), the owner of the file as seen in windows explorer is showing up as my username. I want it to be the owner as it shows up on the remote host.
What is your SSH/SFTP server software?

SSH software: OpenSSH_3.0.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,266
Location:
Prague, Czechia

Re: Maintaining file ownership while copying/transferring fi

That's strange. WinSCP OpenSSH it should work. Can you post a log file?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum