Automated task fails when interactive OK

Advertisement

Jiri Hovorka
Guest

Automated task fails when interactive OK

When I use WinSCP in interactive mode, everything works perfect (upload, download, file deletion).

Scripting the same task fails when uploading files in WinSCP versions 5.5.3 b4214 and 5.1.5 b3261 - log with comments is included. Transfer fails with Status code: 2, Message: 2563, Server: File not found.

I have tried put/mput with all the options explicitly (no combination worked) and setting everything in the INI file with no luck. Pitty is, that the server does not let me open console:(

Maybe I overlooked something stupid:) Can you please help?
Free beer for the help!
Description: a part of the log with comments

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,070
Location:
Prague, Czechia

Re: Automated task fails when interactive OK

The problem might by that you are using backslash in remote path instead of forward slash: put readme.txt .\

Last edited by martin on 2014-06-05; edited 1 time in total

Reply with quote

Jiri Hovorka
Guest

...ohhh my! - 5 people looked into it and overlooked just one little character:)
put readme.txt ./ worked

The beer is yours - i will write to your email.

Reply with quote

Advertisement

You can post new topics in this forum