"System Error" when trying to save configuration: "Code: 5"

Advertisement

s427
Guest

"System Error" when trying to save configuration: "Code: 5"

Hi,

I get the following error when I make a change to my saved sites and click on "save" :

Error writting to file 'C:\Program Files (x86)\WinSCP\WinSCP.ini'
System Error. Code: 5.
Access is denied

(Note: small mistake in the error text: "writting" with 2 "t" instead of 1.)

I'm on Windows 8.1 and I think this is related to the UAC system: the problem doesn't appear when I run WinSCP as an administrator.

My question is: am I really required to run WinSCP with admin privileges every time I simply want to change some configuration options? That doesn't seem right, no other software does that. Am I missing something and is there another way to solve this?

Thanks in advance.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: "System Error" when trying to save configuration: "Code: 5"

s427 wrote:

My question is: am I really required to run WinSCP with admin privileges every time I simply want to change some configuration options? That doesn't seem right, no other software does that. Am I missing something and is there another way to solve this?
Of course not. WinSCP would never try to write the INI file to Program Files folder, unless you forced it. You had possibly WinSCP running with admin privileges in the past, when you switched to using INI file. Do you really want to use INI file at all? INI file is typically used for portability, i.e. when WinSCP is not installed. If you do not want to use INI file, switch to using Windows Registry (what is default when WinSCP is installed).
Or move your INI file to C:\Username\username\AppData\Roaming\WiSCP.ini. WinSCP will do it for you if you switch to Windows Registry (running as admin) and than back to INI file (running as non-admin).
For details, see:
https://winscp.net/eng/docs/config
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: "System Error" when trying to save configuration: "Code: 5"

s427 wrote:

(Note: small mistake in the error text: "writting" with 2 "t" instead of 1.)
I have fixed that. Thanks.

Reply with quote

Advertisement

You can post new topics in this forum