Topic "Why can't I modify files on ubuntu when I am connecting with"

Author Message
[View user's profile]

Joined: 2014-07-17
Posts: 1
Location: Taipei, Taiwan
I'm using the latest version and on Windows 7 via SFTP protocol

I've tried different ways and read some solutions including these:
Why I am not able to ssh as root?
Editing with Winscp
And an article from this Forum of

I don't understand why when I connect with ubuntu via putty, I can have root permission and modify files. However, when I connect with ubuntu via WinSCP, I'm another user(I used the same username and same private key(pem) on both connecting software) and can't modify files.

Then I found some possible solutions from the links above. I tried to set root password and permitRootLogin. But then, when I log in with the root username, it says the file is too big, whereas when I changed the username back to ubuntu, then it works(file is size has no problem, but I can't modify files when I'm not root user).

I am very confused, please anybody if you can point me out, I'd be much appreciated.
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26890
Location: Prague, Czechia
Your duplicate question (with my answer) on

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License