no read permission = can't upload

Advertisement

bigfoot.xxl
Guest

no read permission = can't upload

I need to upload to a ftp site where there is no read permission but winscp is aborting the upload (I tested with read permission ON and it worked just fine but I cant leave it like that):
< 2014-07-23 13:58:41.666 227 Entering Passive Mode (10,253,1,178,19,94).
> 2014-07-23 13:58:41.666 LIST
< 2014-07-23 13:58:41.682 125 Data connection already open; Transfer starting.
. 2014-07-23 13:58:41.682 <Empty directory listing>
< 2014-07-23 13:58:41.688 550 .: Access is denied.
. 2014-07-23 13:58:41.688 Copying files to remote side failed.
* 2014-07-23 13:58:41.688 (ExtException) **Copying files to remote side failed.**
* 2014-07-23 13:58:41.688 .: Access is denied.

I assume the LIST command is the problem here... can I disable it? (windows ftp.exe does this just fine but has other problems) Here is my current command:

WinSCP.exe /command "open ftp://anonymous:test@192.168.1.178/" "put -delete c:\temp\*.txt /" "exit"

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: no read permission = can't upload

I have tried this against various servers, but was not able to reproduce this. Yes, the LIST (or MLSD) is used, but there's no problem even if the server responds with 550. What FTP server are you connecting to? Can you attach a complete session log file?

Reply with quote

bigfoot.xxl
Guest

Re: no read permission = can't upload

The first in the logs is an WinXP machine and the second server is Win 2003 R2 SP2 - no difference with 5.1.7 nor 5.5.4.
  • winscp5.1.7.log (13.91 KB, Private file)
  • winscp5.5.4.log (10.97 KB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

Re: no read permission = can't upload

Thanks for the log. I do not have 2003 to test it myself. I've tried 2008 R2 IIS and it works fine.

The difference seems to be that while 2008 rejects listing straightaways, 2003 seems to start data connection for the listing and fails only after that.

> 2014-08-06 12:27:42.348 LIST
< 2014-08-06 12:27:42.359 125 Data connection already open; Transfer starting.
. 2014-08-06 12:27:42.360 <Empty directory listing>
< 2014-08-06 12:27:42.567 550 .: Access is denied.
. 2014-08-06 12:27:42.567 Copying files to remote side failed.

VS.

> 2014-08-08 12:27:20.088 LIST
. 2014-08-08 12:27:20.089 <Empty directory listing>
< 2014-08-08 12:27:20.089 550 Access is denied.
...
> 2014-08-08 12:27:20.094 STOR RaveBE77.ini
< 2014-08-08 12:27:20.095 150 Opening BINARY mode data connection.
< 2014-08-08 12:27:20.095 226 Transfer complete.
. 2014-08-08 12:27:20.095 Upload successful

But that's difficult for me to verify without having server to test against. Any change to get a test account on your server?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,262
Location:
Prague, Czechia

bigfoot.xxl wrote:

Sure, I would need your external IP but I don't want to put my email here, so how do I contact you?
You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum