Problem running automated WinSCP from ASPX .NET4 application

Advertisement

soea@...
Guest

Problem running automated WinSCP from ASPX .NET4 application

Hi

I have followed all steps suggested in Bug report 996.

Every time i try to do an upload from my ASPX application i get an error:

"Timeout waiting for WinSCP to respond - WinSCP has not responded in time (response log file C:\TEMP\wscp0470.015AE793.tmp was not created). This could indicate lack of write permissions to the log folder or problems starting WinSCP itself."

I am using Winscp.dll 1.1.7.4605 and i have the EXE file with version 5.5.5.4605 located in the same folder (bin folder on IIS)

I have restarted the server after installing never version (it has never worked for me)

I have registered for COM and have given Everyone Modify access to C:\TEMP and also to the folder configured for Logging (Also tried disabling logging)

I can however run the GUI and upload/download file without any problems. It is only the automation from my .NET application that fails.

Windows server is version 2008 SP2 64bit.
My application is running .NET4

I hope you have some good advice, since i like your product :-)

Kind regards
Søren Andersen

Reply with quote

Advertisement

sorenaa
Joined:
Posts:
1
Location:
Denmark

Still not working using Beta 5.6.1

Hi

I am sorry to say that using version 5.6.1 did not help. I still get the same error message:
"WinSCP has not responded in time (response log file C:\TEMP\wscp04C4.01EAE3A9.tmp was not created). This could indicate lack of write permissions to the log folder or problems starting WinSCP itself."

Other suggestions will be greatly appreciated.

Søren

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Still not working using Beta 5.6.1

I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
_________________
Martin Prikryl

Reply with quote

jmartife
Guest

Problem running Powershell sript

Hi

We are developing a Powershell script to download some files automatically.
In tests on a computer with Windows 7 Professional SP1 64 we have had no problems.
When we copy it into a Windows 2008 R2 64 bit, the execution always gives us the error "EXCEPTION - Timeout waiting for answer-to WinSCP - WinSCP has not Responded in time (response log file C: \ Users \ Administrator \ AppData \ Local \ Temp \ 2 \ wscp10B0.034CCD1B.tmp was not created). Could This Indicate lack of write permissions to the log folder or problems starting WinSCP itself..Exception.Message "
We tried to change the location of the LOG and didn't work.
We also try to run it on a Windows 2012 + WinSCP version 5.6.1 and did not work.

Regards.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Problem running Powershell sript

jmartife wrote:

We are developing a Powershell script to download some files automatically.
In tests on a computer with Windows 7 Professional SP1 64 we have had no problems.
When we copy it into a Windows 2008 R2 64 bit, the execution always gives us the error "EXCEPTION - Timeout waiting for answer-to WinSCP - WinSCP has not Responded in time (response log file C: \ Users \ Administrator \ AppData \ Local \ Temp \ 2 \ wscp10B0.034CCD1B.tmp was not created). Could This Indicate lack of write permissions to the log folder or problems starting WinSCP itself..Exception.Message "
We tried to change the location of the LOG and didn't work.
We also try to run it on a Windows 2012 + WinSCP version 5.6.1 and did not work.
Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

jmartife
Guest

Re: Problem running Powershell sript

martin wrote:

jmartife wrote:

We are developing a Powershell script to download some files automatically.
In tests on a computer with Windows 7 Professional SP1 64 we have had no problems.
When we copy it into a Windows 2008 R2 64 bit, the execution always gives us the error "EXCEPTION - Timeout waiting for answer-to WinSCP - WinSCP has not Responded in time (response log file C: \ Users \ Administrator \ AppData \ Local \ Temp \ 2 \ wscp10B0.034CCD1B.tmp was not created). Could This Indicate lack of write permissions to the log folder or problems starting WinSCP itself..Exception.Message "
We tried to change the location of the LOG and didn't work.
We also try to run it on a Windows 2012 + WinSCP version 5.6.1 and did not work.
Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Hi

Today, I've tested the new 5.7 version (in the Win 2008 Server R2 64 bit) and the script still fails.

The same error: "EXCEPTION -- Timeout waiting for WinSCP to respond - WinSCP has not responded in time (response log file C:\scripts\Test\Xml.log was not created). This could indicate lack of write permissions to the log folder or problems starting WinSC
P itself..Exception.Message"

In a Windows 2003 R2 Server the script with 5.7 version runs Ok.

Notes:
I have tried the $session.XmlLogPath = "C:\scripts\Test\Xml.log" (admin user have full control over this folder).
I have executed PS ISE with "Run as administrator" option
I have executed cmd and PS console with "Run as administrator" option
UAC is set to "Notify me only when apps try to make changes to my computer"

Regards

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Problem running Powershell sript

jmartife wrote:

Today, I've tested the new 5.7 version (in the Win 2008 Server R2 64 bit) and the script still fails.
Did you contacted me as I've asked you the last time? (I'm sorry, but I cannot remember all the issues).
_________________
Martin Prikryl

Reply with quote

Guest

Re: Problem running Powershell sript

martin wrote:

jmartife wrote:

Today, I've tested the new 5.7 version (in the Win 2008 Server R2 64 bit) and the script still fails.
Did you contacted me as I've asked you the last time? (I'm sorry, but I cannot remember all the issues).

I did not contacted you before. I forgot to send you an email due to our script was moved to a W2003 server (the old version was Winscp.exe 5.5.5.4605 and WinSCPnet.dll 1.1.7.4605).

Today I needed to make a change in the code and I've remembered this post. I've checked your web and I've downloaded the 5.7 version for testing purpose (5.7 version works without problems in the W2003 server and )

Thank you.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Problem running Powershell sript

So, can you send me an email now, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

BAHA KHADIJA
Joined:
Posts:
3
Location:
Maroc

having the same problem in vb.net cript

i also have the same problem i added the winscp dll in my app vb.net when i try to open a session of winscp i get the same error my version winscp is 5.5.6

Reply with quote

Advertisement

You can post new topics in this forum