Authentication Banner keeps appearing

Advertisement

DavidMacLean
Joined:
Posts:
3

Authentication Banner keeps appearing

Version 5.5.4

When I click the 'Never show this banner again' for the Authentication Banner it doesn't save that selection? Every time I open the session I get the Banner?

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Authentication Banner keeps appearing

It prevents only an identical banner from appearing the next time. I assume your banner changes (it may display current time or free disk space or other ever changing information).

Reply with quote

DavidMacLean
Joined:
Posts:
3

Authentication Banner keeps appearing

Unless there is hidden data on the banner it looks the same every time with a simple one line header. This is happening on version 5.5.4 but works on version 4.2.9.

This is happening when I run it manually - GUI. But I'm worried about my scripts hanging on this. Can this be handled in a script somehow?

Reply with quote E-mail

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Authentication Banner keeps appearing

WinSCP does not display banners in script.

Btw, are you running 4.2.9 and 5.5.4 on the same machine? That would explain the problem. Each version (4.x vs. 5.x) uses a different encoding, so checksum of banners are different. And each version consider checksum of the banner calculated by the other version different.

Reply with quote

Advertisement

You can post new topics in this forum