5.6.4RC: Delay when using keyboard to navigate after login

Advertisement

Pathduck
Donor
Joined:
Posts:
79
Location:
Oslo

5.6.4RC: Delay when using keyboard to navigate after login

I notice when using the RC (and previous versions), there is a quite noticable delay when using the keyboard to move around on remote host.

To reproduce (it's tricky so might have to try more than once)

- Login to Linux ending up in /home/username
- cd twice up using backspace to /
- using keyboard, go to /var (v-a-r), press enter
- quickly start typing the name of a dir in /var for instance log, spool or cache.
- notice focus/cursor is not moved and appears stuck on '..'

Possibly repro-able on other server types as well but I don't have others to test.

Version 5.6.4 RC on Windows 2008 Server R2, 64-bit.
Connecting to RHEL 6.5 x86-64 using SFTP (also SCP)

This has been present in the latest versions as well, and hoping it doesn't make it into the Final.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: 5.6.4RC: Delay when using keyboard to navigate after login

Thanks for your report. What is the last version that did not have the issue?

Reply with quote

Pathduck
Donor
Joined:
Posts:
79
Location:
Oslo

Hello Martin,
I think the 5.5.5/6 didn't have it but I have been using 5.6.3 for some time now and it's present there.

It's not a big issue for sure but it gets annoying when I use the keyboard all the time to select directories by typing. It only seems to occur at the start of a session, and since we have servers locally the dir-listing is very fast which might be why I notice it. Usually one would have a remote server and possibly not notice because the time it takes to list.

The delay is just a few seconds but sometimes it won't let me type at all and I have to press down arrow to get focus.

I move a lot to the same folders and usually do it without even looking so for me it's very noticable when it gets stuck.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

The difference between 5.6.2 and 5.6.3 is what happens when you start typing while directory is still loading. With 5.6.3, nothing happens. This is not exactly what you describe, but I believe that it is actually the same issue.

Reply with quote

Pathduck
Donor
Joined:
Posts:
79
Location:
Oslo

martin wrote:

The difference between 5.6.2 and 5.6.3 is what happens when you start typing while directory is still loading. With 5.6.3, nothing happens. This is not exactly what you describe, but I believe that it is actually the same issue.

Ok is there any way around this? I usually go to the same folders a lot, and like to just type very fast to get there. I know I can use profiles/bookmarks but usually it's faster to just type.

Also it just seems to be right after login - when I go to for instance /var and start typing 'log'. So I guess after folder is loaded, it is cached or something.

I will try with 5.6.2 to compare.

Edit; just tested with 5.6.2 and the problem is not present there, so it started with 5.6.3.

Oh and Happy New Year btw :)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

I'll think about it.

Also it just seems to be right after login - when I go to for instance /var and start typing 'log'. So I guess after folder is loaded, it is cached or something.
The issue does not occur, when the directory is loaded from a cache.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum